[SOLVED] No /sys/devices/platform/bcm2708_usb driver control

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

[SOLVED] No /sys/devices/platform/bcm2708_usb driver control

Postby pinoverclock » Wed Jun 24, 2015 9:59 am

I usually control the Pi Usb Hub with /sys/devices/platform/bcm2708_usb
But it has disappeared during the last updates

Any clue?
Last edited by pinoverclock on Thu Jun 25, 2015 9:19 am, edited 1 time in total.
pinoverclock
 
Posts: 15
Joined: Mon Dec 31, 2012 2:05 pm

Re: No /sys/devices/platform/bcm2708_usb driver control

Postby pinoverclock » Thu Jun 25, 2015 9:18 am

After investigating a bit i have found where the bcm2708_usb control is named and located now:

"...
[root@aquarius ~]# dmesg | grep dwc_otg
[ 3.547733] dwc_otg: version 3.00a 10-AUG-2012 (platform bus)
[ 4.003172] WARN::dwc_otg_hcd_init:1047: FIQ DMA bounce buffers: virt = 0xbac14000 dma = 0xfac14000 len=9024
[ 4.038677] dwc_otg: Microframe scheduler enabled
[ 4.061349] dwc_otg 3f980000.usb: DWC OTG Controller
[ 4.067809] dwc_otg 3f980000.usb: new USB bus registered, assigned bus number 1
[ 4.076709] dwc_otg 3f980000.usb: irq 32, io mem 0x00000000
[ 4.117537] usb usb1: Manufacturer: Linux 4.0.6-1-ARCH dwc_otg_hcd
[ 4.143404] dwc_otg: FIQ enabled
[ 4.143418] dwc_otg: NAK holdoff enabled
[ 4.143428] dwc_otg: FIQ split-transaction FSM enabled

[root@aquarius ~]# find /sys/ -name "3f980000.usb"
/sys/bus/platform/devices/3f980000.usb
/sys/bus/platform/drivers/dwc_otg/3f980000.usb
/sys/devices/platform/soc/3f980000.usb

[root@aquarius ~]# ls /sys/devices/platform/soc/3f980000.usb
busconnected disconnect_us fr_interval gotgctl guid hnp hsic_connect mode_ch_tim_en regoffset spramdump uevent
buspower driver gadget gpvndctl gusbcfg hnpcapable inv_sel_hsic pools regvalue srp usb1
bussuspend driver_override ggpio grxfsiz hcd_frrem hprt0 modalias rd_reg_test rem_wakeup_pwrdn srpcapable wr_reg_test
devspeed enumspeed gnptxfsiz gsnpsid hcddump hptxfsiz mode regdump remote_wakeup subsystem
..."


So from now on this is a good way to locate it:
find /sys/devices/ -name `dmesg -t | grep dwc_otg | grep "DWC OTG Controller" | awk '{print $2}' | cut -d":" -f1`

I hope this would help who ever needs it :D
pinoverclock
 
Posts: 15
Joined: Mon Dec 31, 2012 2:05 pm


Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 1 guest