Rotate Touchscreen

This forum is for supported devices using an ARMv7 Amlogic SoC.

Rotate Touchscreen

Postby Moni86 » Sun Mar 27, 2016 2:53 pm

Hello,

I am a novice in the Linux world and currently have problems my touch screen to rotate 90 °.

I own a ODROID c1 + with Ubuntu 14.4.4 LTS ... I've already tried with no success. In ODROID forum was told it is on Linux Video Driver.

This command is currently in my /etc/X11/xorg.conf

Code: Select all
 # X.Org X server configuration file for xfree86-video-mali
Section "Device"
        Identifier "Mali-FBdev"
        Driver "mali"
        Option "fbdev" "/ dev / fb0"
        Option "DRI2" "true"
        Option "DRI2_PAGE_FLIP" "false"
        Option "DRI2_WAIT_VSYNC" "false"
        Option "UMP_CACHED" "true"
        Option "UMP_LOCK" "false"
        Option "SWCursor" "true"
        Option "HWCursor" "false"
EndSection
Section "ServerFlags"
        Option "NoTrapSignals" "true"
        Option "DontZap" "false"
        Option "Blank Time" "0"
        Option "Standby Time" "0"
        Option "SuspendTime" "0"
        Option "OffTime" "0"
EndSection
Section "DRI"
        Mode 0666
EndSection


I had this already tried out:

We've found a better way to handle screen rotation ...

However, de "CW" option renders xrandr rotation useless ...

We modified /etc/X11/xorg.conf ...

In Section "Device" ...

Replaced: Driver "armsoc"
with: Driver "fbdev"

Might need to comment out: Option "fbdev" "/ dev / fb 1"

and added: Option "Rotate" "CW"

That was when my ODROID XU4 also worked only not when C1 +. Here I did not stand out as Driver "armsoc" but "Mali".

Does somebody has any idea? xrandr I had already tried without success

Thanks for any help and suggestion
Moni86
 
Posts: 1
Joined: Sun Mar 27, 2016 2:48 pm

Return to Amlogic

Who is online

Users browsing this forum: No registered users and 1 guest