Install arch on Odroid-C1+

This forum is for supported devices using an ARMv7 Amlogic SoC.

Install arch on Odroid-C1+

Postby hooey » Thu Sep 03, 2015 11:45 pm

Hi,

I just bought a Odroid-C1+ and want to install arch on it. I followed the wiki page for C1 and tried the latest image (updated yesterday I believe), and also the older image (generated at Aug 15th). With both image I get a black screen and the chip seems stalled. The blue light was blinking slowly so I guess it went through the boot and something bad happened when the kernel took over. I can use the openelec image made by wrxtasy without problem, so I think the board itself is OK
hooey
 
Posts: 4
Joined: Thu Sep 03, 2015 11:31 pm

Re: Install arch on Odroid-C1+

Postby sgrin » Fri Sep 04, 2015 11:15 am

I have two C1+ with arch installed and working good. But didn't test them with monitor.
If you could post serial console (UART) output, it would help probably.
sgrin
 
Posts: 6
Joined: Tue Feb 03, 2015 3:19 pm

Re: Install arch on Odroid-C1+

Postby hooey » Sat Sep 05, 2015 3:33 pm

I did not order an uart cable with it since I did not expect the trouble. Anyway, it turns out the system boots fine once I commented out the the "disableuhs" line in boot.ini. I use a samsung evo 32G card with C1+, it seems a few other people with this microsd card also need to do that to make it boot to ubuntu, according to google. However if I "reboot" the system, once the system is back I get tons of
Code: Select all
[aml_sdhc_print_err] sd: data CRC error, port=4, Cmd18 Arg 028584a0, xfer_step=3, status=4, cmd25=489, fifo_empty=0, fifo_full=0, timeout=0, Xfer 4096 Bytes, SEND=0x500d2, iSTA=0x559, STAT=0x26

Shutdown and start it again there is no problem. It seems there are still some compatibility issues with this particular microsd card.
hooey
 
Posts: 4
Joined: Thu Sep 03, 2015 11:31 pm


Return to Amlogic

Who is online

Users browsing this forum: No registered users and 2 guests