Bluetooth broken?

Raspberry Pi 2

Bluetooth broken?

Postby keithspg » Sat May 29, 2021 5:07 pm

Anyone else experiencing bluetooth broken?
It takes many many attempts to pair a keyboard and I can no longer send sound over BT either to or from the RPi.

Is it me or is this more widespread? This used to work merely months ago. I noticed the keyboard pairing issues back in February:
https://github.com/bluez/bluez/issues/55
but had not tried audio in a while. and noticed a reference in another post:
https://github.com/bluez/bluez/issues/84
I wonder if it is a firmware problem instead of a Bluez problem as is referenced in the issue 84. I will try older images and see if I can pinpoint what changed.
keithspg
 
Posts: 147
Joined: Mon Feb 23, 2015 4:14 pm

Re: Bluetooth broken?

Postby keithspg » Sun May 30, 2021 3:52 pm

So, I went back to November 2020. These versions of what I think are relevant packages installed:
bluez 5.55-1
bluez-libs 5.55-1
bluez-utils 5.55-1
firmware-raspberrypi 6-1
linux-firmware 20201113.2ea8667-1
raspberrypi-firmware 20201027-1

I can get it to pair as a BT sink. I can play audio from my phone to the RPi, but cannot pair a keyboard nor a BT headset. I will try farther back
keithspg
 
Posts: 147
Joined: Mon Feb 23, 2015 4:14 pm

Re: Bluetooth broken?

Postby keithspg » Sun May 30, 2021 7:07 pm

went back to September and was able to pair the audio devices phone as source and headphones as sink but still cannot pair the keyboard on the first try. I did not try many many times to see if it would pair, just 2-3 for each one.
This is with kernel 5.4.64 and
Code: Select all
bluez 5.55-1
bluez-libs 5.55-1
bluez-utils 5.55-1
firmware-raspberrypi 6-1
linux-firmware 20200817.7a30af1-1
raspberrypi-firmware 20200820-1

I will try backdating to 5.55 just to see if I can now pair and connect my headphones, but need to look further back to see why it will not pair a keyboard. THe next older images are on my NAS, so I will have to see what I have.
keithspg
 
Posts: 147
Joined: Mon Feb 23, 2015 4:14 pm

Re: Bluetooth broken?

Postby graysky » Mon May 31, 2021 2:02 pm

I have been comparing the firmware RPiOS provides to what we provide and noticed there are a few BCM* missing. I don't have any bluetooth stuff for testing so you will need to try this and report back.

1) Update your system (don't hold any packages back)
2) Build and install this version of firmware-raspberrypi
3) Reboot
4) Try bluetooth stuff and let me know
graysky
 
Posts: 1021
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000

Re: Bluetooth broken?

Postby keithspg » Mon May 31, 2021 6:14 pm

Still looking for some help, here.
I re-rtraced my steps and was wrong about 5.58 and my headphones. Do not know why, but now it works. I conclude that 5.55 and 5.58 have the same problem regardless of the firmware-raspberrypi that is installed. The problem is that I cannot pair a BT keyboard.
I was trying to see if it had something to do with the brcm firmware and built a few firmware-raspberrypi by using git to grab old versions. I tried firmware-raspberrypi 6-1 from 2019 and it will connect to my BT headphones and will connect to my phone as an audio source as will the latest firmware-raspberrypi, but will not pair a keyboard. It cannot accept a 6 digit code typed in from a BT keyboard when attempting to pair. This is with with bluez 5.55 and bluez 5.58. Every attempt looks like this:
Code: Select all
[NEW] Device A4:9A:58:6C:BE:7A Samsung Bluetooth Keyboard EJ-CT800
[bluetooth]# pair  A4:9A:58:6C:BE:7A
Attempting to pair with A4:9A:58:6C:BE:7A
[CHG] Device A4:9A:58:6C:BE:7A Connected: yes
[agent] Passkey: 542669
[agent] Passkey: 542669
[agent] Passkey: 542669
[agent] Passkey: 542669
[agent] Passkey: 542669
[agent] Passkey: 542669
[agent] Passkey: 542669
Failed to pair: org.bluez.Error.AuthenticationFailed
[CHG] Device A4:9A:58:6C:BE:7A Connected: no

I will reset my firmware and try older bluez versions. Next stop bluez 5.51. I'll see if that works.
edit - I cannot build 5.50 with the current ell version. I was able to build 5.51, though. Will try that.
keithspg
 
Posts: 147
Joined: Mon Feb 23, 2015 4:14 pm

Re: Bluetooth broken?

Postby keithspg » Thu Jun 24, 2021 12:44 am

@graysky No dice. I just re-read your last post and built the firmware-raspberrypi and installed it on aarch64 on a b3+. Fully up to date and installed this firmware.

It installed as: firmware-raspberrypi 20210531-1
I can connect audio devices, but just not a simple keyboard.

I get the same result. It tries to pair then fails:
Code: Select all
[bluetooth]# pair  A4:9A:58:6C:BE:7A
Attempting to pair with A4:9A:58:6C:BE:7A
[CHG] Device A4:9A:58:6C:BE:7A Connected: yes
[agent] Passkey: 865409
...
Failed to pair: org.bluez.Error.AuthenticationFailed
[CHG] Device A4:9A:58:6C:BE:7A Connected: no
[DEL] Device A4:9A:58:6C:BE:7A Samsung Bluetooth Keyboard EJ-CT800
keithspg
 
Posts: 147
Joined: Mon Feb 23, 2015 4:14 pm

Re: Bluetooth broken?

Postby graysky » Thu Jun 24, 2021 8:15 am

I don't know. Can you verify functionality of the bluetooth device using another distro like RPiOS? Rule out the hardware is my point.
graysky
 
Posts: 1021
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000

Re: Bluetooth broken?

Postby keithspg » Fri Jun 25, 2021 3:40 pm

@graysky
Sorry to waste your time. I just went through it with RPiOS and it didn't connect. Then I tried it with my Win10 Desktop and it connected but during pairing it also mentioned to hit 'Return' after I typed the 6 digits. I then re-booted into RPIOS and tried it and also typed 'Return' and it paired immediately. Did the same with Arch. So, this is resolved and was a PEBCAK issue. I have been pairing audio devices and those do not require a return and when I went back and tried to connect this keyboard, I did it the same way but it needs a 'Return' to know I have finished as opposed to just looking at the 6 digits... Strange that it would pair w/o a return sometimes.

Keith
keithspg
 
Posts: 147
Joined: Mon Feb 23, 2015 4:14 pm

Re: Bluetooth broken?

Postby andersl » Tue Jul 06, 2021 9:01 pm

I can't use bluetoothe at all, the device is not found. I searched the net, and found that there is a pi-bluetooth package, do we have something like that? https://github.com/RPi-Distro/pi-bluetooth
andersl
 
Posts: 4
Joined: Tue Jul 06, 2021 8:50 pm

Re: Bluetooth broken?

Postby andersl » Thu Jul 08, 2021 11:39 am

I found a solution: https://gist.github.com/sergeygalkin/fa ... 2b502dc542

I believe the 90-pi-bluetooth.rules file is redundant.

And I suggest this is added to the archlinux images, as i actually looks relatively sane. Or you could take inspiration from this, which is even simpler: https://wiki.gentoo.org/wiki/Raspberry_ ... _Bluetooth.
andersl
 
Posts: 4
Joined: Tue Jul 06, 2021 8:50 pm


Return to Broadcom

Who is online

Users browsing this forum: No registered users and 3 guests