Vuze not start

Raspberry Pi 2

Vuze not start

Postby emanuelx » Mon Aug 01, 2016 7:40 pm

Hi, i installed vuze in my rasp 2 through AUR repo, but when i start vuze just crashed.

Code: Select all
Starting Azureus...
Suitable java version found [java = openjdk 1.8.0_102]
Configuring environment...
Java exec found in PATH. Verifying...
find: `/home/emanuelx/.azureus/plugins': No such file or directory
Browser check failed with: org.eclipse.swt.widgets.Display
Auto-scanning for GRE/XULRunner.  You can skip this by appending the GRE path to LD_LIBRARY_PATH and setting
  checking /usr/lib/firefox for GRE
   Can not use GRE from /usr/lib/firefox because it's missing
Browser check failed with: org.eclipse.swt.widgets.Display
Can't create browser.  Will try to set LD_LIBRARY_PATH and hope Vuze has better luck.
GRE/XULRunner automatically found
Loading Azureus:
java -Xmx256m -cp "./Azureus2.jar" -Djava.library.path="/opt/vuze" -Dazureus.install.path="/opt/vuze"
-Dazureus.script="/usr/sbin/vuze" -Dazureus.script.version=5 org.gudy.azureus2.ui.swt.Main
file:/opt/vuze/Azureus2.jar ; file:/opt/vuze/
changeLocale: *Default Language* != English (United States). Searching without country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (United States)' (en_US), using 'English (default)'
   at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
   at sun.reflect.NativeConstructorAccessorImpl.newInstance(
   at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
   at java.lang.reflect.Constructor.newInstance(
   at org.gudy.azureus2.ui.swt.Main.<init>(
   at org.gudy.azureus2.ui.swt.Main.main(
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(
   at java.lang.reflect.Method.invoke(
   at com.aelitis.azureus.launcher.MainExecutor$
Caused by: java.lang.NoClassDefFoundError: org/eclipse/swt/widgets/Listener
   at com.aelitis.azureus.ui.swt.Initializer.<init>(
   ... 12 more
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Listener
   at java.lang.ClassLoader.loadClass(
   at com.aelitis.azureus.launcher.classloading.PrimaryClassloader.loadClass(
   at java.lang.ClassLoader.loadClass(
   ... 13 more
Exit from Azureus complete
No shutdown tasks to do

I really like using this torrent program in my rasberry pi.

Posts: 2
Joined: Mon Aug 01, 2016 7:26 pm

Re: Vuze not start

Postby moonman » Tue Aug 02, 2016 3:23 am

AFAIK Vuze needs screen. So you need to be running a Desktop Environment.
Also, don't you think it will be pretty heavy for RPI? There are many great alternatives: Transmission, Deluge etc.
Pogoplug V4 | GoFlex Home | Raspberry Pi B 512 | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
[armv5] Updated U-Boot | |[armv5] How to install service | [armv5] NAND Rescue System
Posts: 3089
Joined: Sat Jan 15, 2011 3:36 am
Location: Calgary, Canada

Re: Vuze not start

Postby emanuelx » Tue Aug 02, 2016 2:50 pm

Hi, i fixed the issue, is caused by swt.jar librarie :)

yes, i think is heavy. usually I use the deluge, but the vuze has a versions with some modifications for spoofing :)

For now is just a test about the speed, because vuze need a DE, and deluge run in web interface that's really good torrent program.

Edit :p

yap, its really slow xD

I will keep me in the deluge, sounds much better
Posts: 2
Joined: Mon Aug 01, 2016 7:26 pm

Return to Broadcom

Who is online

Users browsing this forum: No registered users and 1 guest