[rpi2] bsdtar: Ignoring malformed pax extended attribute

Raspberry Pi 2

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby iwesley » Wed Jun 21, 2017 9:47 am

i change the "root" property,and passed
chmod g+w root
then bsdtar processed ok.
iwesley
 
Posts: 1
Joined: Wed Jun 21, 2017 9:44 am

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby plokko » Mon Sep 04, 2017 6:57 am

Got same error with a generic image, as other stated you need bsdtar 3.3+, here's a quick guide on debian (should be the same on ubuntu, tested on a new installation of debian 9 ):

if
Code: Select all
bsdtar --version

return bsdtar/libarchive <3.3 proceed with the following:

Code: Select all
su
apt install -y make cmake gcc
wget https://github.com/libarchive/libarchive/archive/v3.3.1.tar.gz
tar -zxvf v3.3.1.tar.gz
cd libarchive-3.3.1
./configure
make
make install

re-check version
Code: Select all
bsdtar --version

should be 3.3.1, now bsdtar should give no more errors.
plokko
 
Posts: 6
Joined: Mon Sep 04, 2017 6:36 am

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby campbell » Tue Oct 03, 2017 11:19 pm

There's not actually a configure script in that libarchive tarball...
campbell
 
Posts: 6
Joined: Wed Aug 30, 2017 11:13 pm

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby 42mileslong » Sat Oct 07, 2017 9:52 pm

https://github.com/helotism/helotism/issues/8

This archive worked for me.

Code: Select all
wget https://www.libarchive.org/downloads/libarchive-3.3.1.tar.gz
tar xzf libarchive-3.3.1.tar.gz
cd libarchive-3.3.1
./configure
make
sudo make install
42mileslong
 
Posts: 1
Joined: Sat Oct 07, 2017 9:50 pm

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby kuleszdl » Mon Nov 27, 2017 9:09 pm

I encountered the same issue on the pcduino3s. I used bsdtar from the 3.3.2 distribution and it worked as well. However, I don't understand why the archive must be packed

- using an exotic archive format
- requiring a very recent version of the archive tool

I agree with the previous posters that the fact that it requires bsdtar 3.3+ should be stated clearly in the installation manual.
kuleszdl
 
Posts: 22
Joined: Fri Dec 21, 2012 11:01 pm

Previous

Return to Broadcom

Who is online

Users browsing this forum: No registered users and 2 guests