[rpi2] bsdtar: Ignoring malformed pax extended attribute

Raspberry Pi 2

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby Kohtachan » Thu Apr 06, 2017 9:59 am

The same problem here

Code: Select all
leon@leon-System-Product-Name:~$ sudo bsdtar -xpf ArchLinuxARM-rpi-2-latest.tar.gz -C root
bsdtar: Ignoring malformed pax extended attribute
bsdtar: Ignoring malformed pax extended attribute
bsdtar: Ignoring malformed pax extended attribute
bsdtar: Ignoring malformed pax extended attribute
bsdtar: Error exit delayed from previous errors.
Kohtachan
 
Posts: 1
Joined: Thu Apr 06, 2017 9:58 am

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby procount » Thu Apr 06, 2017 12:49 pm

Hi, I am the author of PINN - a NOOBS fork that I modified to allow Arch to be installed on the RPi by direct download from the Arch Website.
That had been working fine, but I recently had reports that the installation had stopped working, so I tried it myself and indeed I got the same errors as reported above.

I used the following version:
Code: Select all
ArchLinuxARM-rpi-latest.tar.gz                     05-Apr-2017 05:59           310591672
using bsdtar 3.1.2
md5: 9f96cf2d9cadf1635d918caa91c7b063  ArchLinuxARM-rpi-latest.tar.gz

I even tried to untar the file manually (onto an ext4 fs) to make sure it was not a problem with PINN and I still got the same errors.

It seems there are 4 files which are causing the problem:

Code: Select all
bsdtar: Ignoring malformed pax extended attribute
./usr/bin/ping: Failed to set extended attribute
bsdtar: Ignoring malformed pax extended attribute
./usr/bin/rlogin: Failed to set extended attribute
bsdtar: Ignoring malformed pax extended attribute
./usr/bin/rsh: Failed to set extended attribute
bsdtar: Ignoring malformed pax extended attribute
./usr/bin/rcp: Failed to set extended attribute

I tried this on Ubuntu 14.04 on my PC and got the same errors using bsdtar 3.1.2

The version that I had previously downloaded (and which still works ok) is:
Code: Select all
ArchLinuxARM-rpi-latest.tar.gz  Oct 12  2016   305937722


Has something changed in the tar distribution format since Oct 2016? I have heard there are some subtle differences between the bsdtar and gnutar versions, for example.

(So far I have only tested the RPI1 for armv6 chips, but although this is an armv7 subforum, I thought I should keep the info together instead of starting a new topic)
procount
 
Posts: 2
Joined: Thu Apr 06, 2017 12:46 pm

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby lenz » Mon Apr 17, 2017 9:01 pm

The same issue occurs when trying Arch Linux image for Utilite from this page, which in the end results in a non-bootable SD card. Is there any way to fix this or get previous version of the image before it got corrupted? Thanks.
lenz
 
Posts: 1
Joined: Mon Apr 17, 2017 8:57 pm

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby WarheadsSE » Tue Apr 18, 2017 12:01 pm

It isn't corrupted. If it matches the checksums, it's fine.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6729
Joined: Mon Oct 18, 2010 2:12 pm

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby LRBrian » Wed Apr 19, 2017 9:17 pm

Same as the others...

bsdtar: Ignoring malformed pax extended attribute
bsdtar: Ignoring malformed pax extended attribute
bsdtar: Ignoring malformed pax extended attribute
bsdtar: Ignoring malformed pax extended attribute
bsdtar: Error exit delayed from previous errors.
LRBrian
 
Posts: 1
Joined: Wed Apr 19, 2017 9:15 pm

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby Horloge » Thu Apr 20, 2017 11:45 am

Hello there,

Same problem with that latest image, and the md5 is good too.
I've created an account to report this, 'cause I have to install this image ASAP... Can we have a link to a previous release ?

It looks like this archive is corrupted, or malformed.

Thanks,
Horloge
 
Posts: 3
Joined: Thu Apr 20, 2017 11:40 am

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby vo6oh3 » Sat Apr 22, 2017 4:49 am

Guys, you need to use bsdtar version 3.3+
vo6oh3
 
Posts: 4
Joined: Thu Mar 02, 2017 12:36 pm

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby Horloge » Sat Apr 22, 2017 8:08 am

vo6oh3 wrote:Guys, you need to use bsdtar version 3.3+


Hey,

Are you sure about this version ?
I'm running the latest Debian Stretch, and the higher version I just got is 3.2.2 ...

https://puu.sh/vskXu/d79e1a37ab.png
Horloge
 
Posts: 3
Joined: Thu Apr 20, 2017 11:40 am

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby procount » Sat Apr 22, 2017 8:12 am

@vo6oh3 - Thanks. I'm compiling bsdtar 3.3.1 now so I'll see how it goes.

UPDATE: I tested ArchLinuxARM-rpi-latest.tar.gz with a newly compiled bsdtar 3.3.1 and it now works fine. Thanks.
procount
 
Posts: 2
Joined: Thu Apr 06, 2017 12:46 pm

Re: [rpi2] bsdtar: Ignoring malformed pax extended attribute

Postby Horloge » Sat Apr 22, 2017 8:57 am

Yes I confirm that extracting with 3.3+ is working without any error [but my my Pi is not booting anyway]...

I think you may close this forum, but it'd be good writing in CAPITAL LETTERS this requirement, mostly for Debian / Ubuntu users, 'cause they can't install bsdtar 3.3 with official repositories...
Horloge
 
Posts: 3
Joined: Thu Apr 20, 2017 11:40 am

PreviousNext

Return to Broadcom

Who is online

Users browsing this forum: No registered users and 1 guest