[Solved][Raspberry Pi 3] Kodi visualisations not showing up

Raspberry Pi 2

[Solved][Raspberry Pi 3] Kodi visualisations not showing up

Postby andre » Mon Apr 03, 2017 7:09 pm

I have recently bought a Raspberry Pi 3 to replace my Banana Pi to run Kodi. As I am running the Raspberry Pi 2 image (to have hardware acceleration) I am posting this in the ARMv7 Broadcom section.

I have installed "kodi-rbp" and "kodi-rbp-addon-visualization-spectrum". However, in the audio options where I select the visualisation, the only option available is "none". When I activate debugging, I see
Code: Select all
DEBUG: ADDON: cpluff: 'Plug-in visualization.spectrum has been installed.'

which suggests the visualisation has been loaded.

The files are present in the file system, and there appear to be no missing libraries either
Code: Select all
[andre@rpi-media ~]$ ldd /usr/lib/kodi/addons/visualization.spectrum/visualization.spectrum.so.1.1.1
   linux-vdso.so.1 (0x7ed52000)
   libbrcmGLESv2.so => /opt/vc/lib/libbrcmGLESv2.so (0x76ebd000)
   libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x76d6b000)
   libm.so.6 => /usr/lib/libm.so.6 (0x76ce6000)
   libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x76cb9000)
   libc.so.6 => /usr/lib/libc.so.6 (0x76b70000)
   /usr/lib/ld-linux-armhf.so.3 (0x54b8d000)
   libbrcmEGL.so => /opt/vc/lib/libbrcmEGL.so (0x76b37000)
   libbcm_host.so => /opt/vc/lib/libbcm_host.so (0x76b10000)
   libvchiq_arm.so => /opt/vc/lib/libvchiq_arm.so (0x76afa000)
   libvcos.so => /opt/vc/lib/libvcos.so (0x76ae0000)
   libpthread.so.0 => /usr/lib/libpthread.so.0 (0x76ab5000)
   libdl.so.2 => /usr/lib/libdl.so.2 (0x76aa0000)
   librt.so.1 => /usr/lib/librt.so.1 (0x76a89000)


I don't see what is wrong with this configuration. Am I overlooking something here?

EDIT: I found the problem. The visualisation plugin has to be enabled manually through the addons menu,
andre
 
Posts: 46
Joined: Wed Jan 25, 2012 1:39 pm
Location: Eindhoven

Return to Broadcom

Who is online

Users browsing this forum: No registered users and 1 guest