no channel scan from tvheadend on a raspberry pi 2

Raspberry Pi 2

no channel scan from tvheadend on a raspberry pi 2

Postby JoergZ » Thu Feb 12, 2015 1:31 pm

Problem:
I want to set up Tvheadend on a Raspberry Pi 2 with Archlinux. Archlinux is the fastest system booting and running. IMHO all hardware and drivers are ok. The log files and protocols are below. Tvheadend is unable to do a channel scan. When I choose the satellite Astra 19.2 and set the other suggested options and click the Save button nothing happens. Nothing appears under "Currently tuned to" or "Muxes" or "Muxes awaiting initial scan"!

A test with LXDE/Kaffeine was succesfull. Kaffeine finds all the needed channels. I've tested the same Pi Board with Raspbian and it runs Tvheadend without any problem. I don't know whether Archlinux or Tvheadend is the problem. Maybe anayone has some experiences with that combination and can help. What is wrong?

Hardware:
Raspberry Pi 2
Tevii S660 USB S2 Revćeiver

OS:
Linux alarmpi 3.18.6-2-ARCH #1 SMP PREEMPT Sun Feb 8 09:40:23 MST 2015 armv7l GNU/Linux

Tvheadend version:
at Pi 2 compiled tvheadend-3.4.27-2-armv7h.pkg.tar.xz
using this Howto: http://kodi.wiki/view/HOW-TO:Install_Tv ... Arch_Linux

Content of lsusb:
Code: Select all
Bus 001 Device 004: ID 9022:d660 TeVii Technology Ltd. DVB-S2 S660
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub



Content of lsmod:
Code: Select all
Module                  Size  Used by
rpcsec_gss_krb5        21136  0
evdev                   9464  0
rc_tevii_nec            1180  0
ts2020                  4274  1
ds3000                 11971  1
dvb_usb_dw2102         40541  0
dvb_usb                18283  1 dvb_usb_dw2102
dvb_core               90917  1 dvb_usb
rc_core                21274  4 dvb_usb,rc_tevii_nec,dvb_usb_dw2102
leds_gpio               3530  0
led_class               4035  1 leds_gpio
uio_pdrv_genirq         3281  0
uio                     8710  1 uio_pdrv_genirq
sch_fq_codel            7252  2
snd_bcm2835            20881  2
snd_pcm                86661  2 snd_bcm2835
snd_timer              19608  1 snd_pcm
snd                    60836  6 snd_bcm2835,snd_timer,snd_pcm
bcm2708_rng             1143  0
rng_core                5666  1 bcm2708_rng
ipv6                  342650  40



Content of dmesg | grep dvb
Code: Select all
[    9.625954] dvb-usb: found a 'TeVii S660 USB' in cold state, will try to load a firmware
[    9.716657] dvb-usb: downloading firmware from file 'dvb-usb-s660.fw'
[    9.849739] dvb-usb: found a 'TeVii S660 USB' in warm state.
[    9.856621] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[    9.955173] dvb-usb: MAC address: 00:18:bd:5b:61:d1
[   10.104610] dvb-usb: schedule remote query interval to 150 msecs.
[   10.112744] dvb-usb: TeVii S660 USB successfully initialized and connected.


Content of journalctl | grep tvheadend
Code: Select all
Feb 12 12:08:40 alarmpi systemd[1]: Started tvheadend.
Feb 12 12:08:40 alarmpi tvheadend[271]: charset: 71 entries loaded
Feb 12 12:08:40 alarmpi tvheadend[271]: dvb: Found adapter /dev/dvb/adapter0 (Montage Technology DS3000) via USB (480 Mbit/s)
Feb 12 12:08:40 alarmpi tvheadend[271]: dvb: Adapter /dev/dvb/adapter0 will run in filtered mode
Feb 12 12:08:40 alarmpi tvheadend[271]: CSA: Using 32bit parallel descrambling
Feb 12 12:08:40 alarmpi tvheadend[271]: epggrab: module eit created
Feb 12 12:08:40 alarmpi tvheadend[271]: epggrab: module uk_freesat created
Feb 12 12:08:40 alarmpi tvheadend[271]: epggrab: module uk_freeview created
Feb 12 12:08:40 alarmpi tvheadend[271]: epggrab: module viasat_baltic created
Feb 12 12:08:40 alarmpi tvheadend[271]: epggrab: module opentv-ausat created
Feb 12 12:08:40 alarmpi tvheadend[271]: epggrab: module opentv-skyit created
Feb 12 12:08:40 alarmpi tvheadend[271]: epggrab: module opentv-skyuk created
Feb 12 12:08:40 alarmpi tvheadend[271]: epggrab: module pyepg created
Feb 12 12:08:40 alarmpi tvheadend[271]: epggrab: module xmltv created
Feb 12 12:08:40 alarmpi tvheadend[271]: epgdb: loaded v2
Feb 12 12:08:40 alarmpi tvheadend[271]: epgdb:   channels   0
Feb 12 12:08:40 alarmpi tvheadend[271]: epgdb:   brands     0
Feb 12 12:08:40 alarmpi tvheadend[271]: epgdb:   seasons    0
Feb 12 12:08:40 alarmpi tvheadend[271]: epgdb:   episodes   0
Feb 12 12:08:40 alarmpi tvheadend[271]: epgdb:   broadcasts 0
Feb 12 12:08:40 alarmpi tvheadend[271]: dvr: Creating new configuration ''
Feb 12 12:08:40 alarmpi tvheadend[271]: START: HTS Tvheadend version  started, running as PID:271 UID:1337 GID:91, settings located in '/home/hts/.hts/tvheadend'
Feb 12 12:08:41 alarmpi tvheadend[271]: AVAHI: Service 'Tvheadend' successfully established.



Content of Web-Interface Tvheadend
Main Window: Configuration -> TV Adapters - General
Sub-Window: Information and Capabilities shows:

Hardware
Device path:
/dev/dvb/adapter0
Device name:
Montage Technology DS3000
Host connection:
USB (480 Mbit/s)
Intermediate Frequency range:
950000 kHz - 2150000 kHz, in steps of 1011 kHz
Symbolrate range:
1000000 Baud - 45000000 Baud
Status
Currently tuned to:

Services:
0
Muxes:
0
Muxes awaiting initial scan:
0
Signal Strength:
0%
Bit Error Rate:
0/s
Uncorrected Bit Errors:
0/s

Any ideas?
JoergZ
 
Posts: 3
Joined: Thu Feb 12, 2015 1:25 pm

Re: no channel scan from tvheadend on a raspberry pi 2

Postby WarheadsSE » Thu Feb 12, 2015 4:22 pm

Try this: https://aur.archlinux.org/packages/tvheadend-git/

Note, read the comments about missing dependencies.
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6743
Joined: Mon Oct 18, 2010 2:12 pm

Re: no channel scan from tvheadend on a raspberry pi 2

Postby JoergZ » Fri Feb 13, 2015 8:21 am

Thank you. But I tested this compilation too with the same result. In the meantime I got the solution or better a workaround:
https://tvheadend.org/boards/4/topics/15336?r=15344
I'm still interested in the root cause. At the moment: problem solved.
JoergZ
 
Posts: 3
Joined: Thu Feb 12, 2015 1:25 pm

Re: no channel scan from tvheadend on a raspberry pi 2

Postby nukru » Tue Feb 17, 2015 9:42 pm

I have the same problem with my raspberrypi (1) and pc (with archlinux).

I think that it's a problem with the "last" kernel version and tvheadend. In raspberrypi and kernel 3.12 update not find anything neither adding mux manually.

In pc and raspberry with kernel update (3.18.x) nothing appears, but if i add mux manually, then tvheadend scan theses mux and everything works fine (this works also in rpi)

I don't remember which application to use to get the mux (somthing command line app)

Moreover, with kaffeine I've never had any problems with any kernel in pc.

pd: in some kernel version(mmm... <3.12) all works fine, including the search for new mux, but in an update (kernel) that was broken. I discovered when in Spain changed DVB-T channels to other frequency.

pd2: I had not read that you had already found the solution
nukru
 
Posts: 2
Joined: Wed Jan 08, 2014 11:07 am


Return to Broadcom

Who is online

Users browsing this forum: Bing [Bot] and 1 guest