Raspberry FBTURBO xorg hw acceleration issue (tested on pi2)

Raspberry Pi 2

Raspberry FBTURBO xorg hw acceleration issue (tested on pi2)

Postby eriktheitalian » Fri Feb 20, 2015 1:41 pm

Im installed official archarm for rpi2. Im using slim display manager. Im using xfce destop.

When i moved a window result not like raspbian. Slow with tearings. Arch have uptdated software sources. There is lots of good. But i need some advice.

Here my last xorg log.

[ 10.422]
X.Org X Server 1.17.1
Release Date: 2015-02-10
[ 10.422] X Protocol Version 11, Revision 0
[ 10.423] Build Operating System: Linux 3.10.63-6-ARCH armv7l
[ 10.423] Current Operating System: Linux alarmpi 3.18.7-6-ARCH #1 SMP PREEMPT Thu Feb 19 21:35:24 MST 2015 armv7l
[ 10.423] Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2709.boardrev=0xa01041 bcm2709.serial=0x1c250426 smsc95xx.macaddr=B8:27:EB:25:04:26 bcm2708_fb.fbswap=1 bcm2709.disk_led_gpio=47 bcm2709.disk_led_active_low=0 sdhci-bcm2708.emmc_clock_freq=250000000 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 root=/dev/mmcblk0p2 rw rootwait console=ttyAMA0,115200 console=tty1 selinux=0 plymouth.enable=0 smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 kgdboc=ttyAMA0,115200 elevator=noop
[ 10.423] Build Date: 15 February 2015 04:35:35AM
[ 10.423]
[ 10.423] Current version of pixman: 0.32.6
[ 10.423] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 10.423] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 10.424] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 20 12:40:34 2015
[ 10.448] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 10.448] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 10.455] (==) No Layout section. Using the first Screen section.
[ 10.455] (==) No screen section available. Using defaults.
[ 10.455] (**) |-->Screen "Default Screen Section" (0)
[ 10.455] (**) | |-->Monitor "<default monitor>"
[ 10.462] (==) No device specified for screen "Default Screen Section".
Using the first device section listed.
[ 10.462] (**) | |-->Device "Alwinner A10/A13 FBDEV`"
[ 10.462] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 10.462] (==) Automatically adding devices
[ 10.462] (==) Automatically enabling devices
[ 10.463] (==) Automatically adding GPU devices
[ 10.474] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF/".
[ 10.475] Entry deleted from font path.
[ 10.475] (Run 'mkfontdir' on "/usr/share/fonts/OTF/").
[ 10.475] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 10.475] Entry deleted from font path.
[ 10.487] (==) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/
[ 10.487] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 10.487] (**) Extension "Composite" is enabled
[ 10.487] (**) Extension "XFree86-DRI" is enabled
[ 10.487] (**) Extension "XFree86-VidModeExtension" is enabled
[ 10.487] (**) Extension "XFree86-DGA" is enabled
[ 10.487] (**) Extension "DOUBLE-BUFFER" is enabled
[ 10.487] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 10.488] (II) Loader magic: 0x1dfec8
[ 10.488] (II) Module ABI versions:
[ 10.488] X.Org ANSI C Emulation: 0.4
[ 10.489] X.Org Video Driver: 19.0
[ 10.489] X.Org XInput driver : 21.0
[ 10.489] X.Org Server Extension : 9.0
[ 10.494] (EE) systemd-logind: failed to get session: PID 204 does not belong to any known session
[ 10.495] (II) no primary bus or device found
[ 10.497] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[ 10.497] (II) LoadModule: "fb"
[ 10.499] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 10.506] (II) Module fb: vendor="X.Org Foundation"
[ 10.506] compiled for 1.17.1, module version = 1.0.0
[ 10.506] ABI class: X.Org ANSI C Emulation, version 0.4
[ 10.506] (II) LoadModule: "dbe"
[ 10.506] (II) Module "dbe" already built-in
[ 10.506] (II) LoadModule: "extmod"
[ 10.506] (II) Module "extmod" already built-in
[ 10.506] (II) LoadModule: "glx"
[ 10.533] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 10.619] (II) Module glx: vendor="X.Org Foundation"
[ 10.619] compiled for 1.17.1, module version = 1.0.0
[ 10.619] ABI class: X.Org Server Extension, version 9.0
[ 10.619] (==) AIGLX enabled
[ 10.619] (II) LoadModule: "dri"
[ 10.619] (II) Module "dri" already built-in
[ 10.619] (II) LoadModule: "record"
[ 10.620] (II) Module "record" already built-in
[ 10.620] (II) LoadModule: "fbturbo"
[ 10.620] (II) Loading /usr/lib/xorg/modules/drivers/fbturbo_drv.so
[ 10.624] (II) Module fbturbo: vendor="X.Org Foundation"
[ 10.624] compiled for 1.17.1, module version = 0.5.1
[ 10.625] Module class: X.Org Video Driver
[ 10.625] ABI class: X.Org Video Driver, version 19.0
[ 10.625] (II) FBTURBO: driver for framebuffer: fbturbo
[ 10.625] (++) using VT number 7

[ 10.641] (WW) Falling back to old probe method for fbturbo
[ 10.641] (II) Loading sub module "fbdevhw"
[ 10.641] (II) LoadModule: "fbdevhw"
[ 10.641] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 10.644] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 10.644] compiled for 1.17.1, module version = 0.0.2
[ 10.645] ABI class: X.Org Video Driver, version 19.0
[ 10.645] (II) FBTURBO(0): using /dev/fb0
[ 10.645] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 10.645] (II) FBTURBO(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 16/16
[ 10.645] (==) FBTURBO(0): Depth 16, (==) framebuffer bpp 16
[ 10.645] (==) FBTURBO(0): RGB weight 565
[ 10.645] (==) FBTURBO(0): Default visual is TrueColor
[ 10.645] (==) FBTURBO(0): Using gamma correction (1.0, 1.0, 1.0)
[ 10.645] (II) FBTURBO(0): hardware: BCM2708 FB (video memory: 4050kB)
[ 10.646] (**) FBTURBO(0): Option "fbdev" "/dev/fb0"
[ 10.646] (**) FBTURBO(0): Option "SwapbuffersWait" "true"
[ 10.646] (II) FBTURBO(0): processor: ARM Cortex-A7
[ 10.646] (II) FBTURBO(0): checking modes against framebuffer device...
[ 10.646] (II) FBTURBO(0): checking modes against monitor...
[ 10.646] (--) FBTURBO(0): Virtual size is 1920x1080 (pitch 1920)
[ 10.647] (**) FBTURBO(0): Built-in mode "current"
[ 10.647] (==) FBTURBO(0): DPI set to (96, 96)
[ 10.647] (II) Loading sub module "fb"
[ 10.647] (II) LoadModule: "fb"
[ 10.647] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 10.647] (II) Module fb: vendor="X.Org Foundation"
[ 10.647] compiled for 1.17.1, module version = 1.0.0
[ 10.647] ABI class: X.Org ANSI C Emulation, version 0.4
[ 10.670] (II) FBTURBO(0): using backing store heuristics
[ 10.680] (II) FBTURBO(0): can't load 'g2d_23' kernel module
[ 10.680] (II) FBTURBO(0): failed to enable the use of sunxi display controller
[ 10.681] (II) FBTURBO(0): No sunxi-g2d hardware detected (check /dev/disp and /dev/g2d)
[ 10.681] (II) FBTURBO(0): G2D hardware acceleration can't be enabled
[ 10.681] (II) FBTURBO(0): enabled fbdev copyarea acceleration
[ 10.681] (**) FBTURBO(0): Option "BackingStore" "off"
[ 10.681] (**) FBTURBO(0): Backing store disabled
[ 10.689] (==) FBTURBO(0): DPMS enabled
[ 10.690] (II) FBTURBO(0): failed to enable hardware cursor
[ 10.690] (II) FBTURBO(0): no 3D acceleration because the driver has been compiled without libUMP
[ 10.690] (II) FBTURBO(0): if this is wrong and needs to be fixed, please check ./configure log
[ 10.690] (==) RandR enabled
[ 10.740] (II) AIGLX: Screen 0 is not DRI2 capable
[ 10.740] (EE) AIGLX: reverting to software rendering
[ 11.479] (II) AIGLX: Loaded and initialized swrast
[ 11.479] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[ 12.440] (II) config/udev: Adding input device Logitech Unifying Device. Wireless PID:4024 (/dev/input/event0)
[ 12.440] (**) Logitech Unifying Device. Wireless PID:4024: Applying InputClass "evdev pointer catchall"
[ 12.441] (**) Logitech Unifying Device. Wireless PID:4024: Applying InputClass "evdev keyboard catchall"
[ 12.441] (**) Logitech Unifying Device. Wireless PID:4024: Applying InputClass "libinput pointer catchall"
[ 12.441] (**) Logitech Unifying Device. Wireless PID:4024: Applying InputClass "libinput keyboard catchall"
[ 12.441] (II) LoadModule: "libinput"
[ 12.443] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[ 12.459] (II) Module libinput: vendor="X.Org Foundation"
[ 12.459] compiled for 1.17.1, module version = 0.6.0
[ 12.460] Module class: X.Org XInput Driver
[ 12.460] ABI class: X.Org XInput driver, version 21.0
[ 12.460] (II) Using input driver 'libinput' for 'Logitech Unifying Device. Wireless PID:4024'
[ 12.460] (**) Logitech Unifying Device. Wireless PID:4024: always reports core events
[ 12.460] (**) Option "Device" "/dev/input/event0"
[ 12.462] (II) input device 'Logitech Unifying Device. Wireless PID:4024', /dev/input/event0 is a pointer caps = relative-motion button
[ 12.462] (II) input device 'Logitech Unifying Device. Wireless PID:4024', /dev/input/event0 is a keyboard
[ 12.530] (**) Option "config_info" "udev:/sys/devices/platform/bcm2708_usb/usb1/1-1/1-1.2/1-1.2:1.2/0003:046D:C52B.0003/0003:046D:C52B.0004/input/input0/event0"
[ 12.530] (II) XINPUT: Adding extended input device "Logitech Unifying Device. Wireless PID:4024" (type: MOUSE, id 6)
[ 12.532] (**) Option "AccelerationScheme" "none"
[ 12.532] (**) Logitech Unifying Device. Wireless PID:4024: (accel) selected scheme none/0
[ 12.532] (**) Logitech Unifying Device. Wireless PID:4024: (accel) acceleration factor: 2.000
[ 12.532] (**) Logitech Unifying Device. Wireless PID:4024: (accel) acceleration threshold: 4
[ 12.533] (II) input device 'Logitech Unifying Device. Wireless PID:4024', /dev/input/event0 is a pointer caps = relative-motion button
[ 12.533] (II) input device 'Logitech Unifying Device. Wireless PID:4024', /dev/input/event0 is a keyboard
[ 12.536] (II) config/udev: Adding input device Logitech Unifying Device. Wireless PID:4024 (/dev/input/mouse0)
[ 12.536] (II) No input driver specified, ignoring this device.
[ 12.536] (II) This device may have been added with another device file.
[ 752.225] (EE) FBTURBO(0): FBIOBLANK: Operation not permitted
[ 1052.226] (EE) FBTURBO(0): FBIOBLANK: Operation not permitted
[ 2482.555] (EE) FBTURBO(0): FBIOBLANK: Operation not permitted
[ 2782.600] (EE) FBTURBO(0): FBIOBLANK: Operation not permitted
eriktheitalian
 
Posts: 8
Joined: Fri Feb 20, 2015 1:28 pm

Return to Broadcom

Who is online

Users browsing this forum: No registered users and 1 guest