SOLVED: mariadb stopped working aarch64 (EspressoBIN, RPi3)

This forum is for topics dealing with problems with software specifically in the AArch64 repo.

SOLVED: mariadb stopped working aarch64 (EspressoBIN, RPi3)

Postby jernst » Fri Oct 20, 2017 11:33 pm

Code: Select all
[root@alarm ~]# mysqld   
[   89.223741] mysqld[282]: unhandled level 0 translation fault (11) at 0xffffffff96861000, esr 0x92000004, in libjemalloc.so.2[ffff9741a000+4c000]
[   89.237246] CPU: 1 PID: 282 Comm: mysqld Not tainted 4.13.8-1-ARCH #1
[   89.243826] Hardware name: Globalscale Marvell ESPRESSOBin Board (DT)
[   89.250426] task: ffff800038bcd400 task.stack: ffff8000397f4000
[   89.256467] PC is at 0xffff9744c938
[   89.259931] LR is at 0xffff9744c92c
[   89.263618] pc : [<0000ffff9744c938>] lr : [<0000ffff9744c92c>] pstate: 60000000
[   89.271369] sp : 0000ffffeeb13fd0
[   89.274772] x29: 0000ffffeeb13fd0 x28: 87c37b91114253d5
[   89.280464] x27: ffffffff96861000 x26: 0000ffff9685d3c8
[   89.285897] x25: 0000ffff96a5c738 x24: 0000ffff9685a980
[   89.291355] x23: ff51afd7ed558ccd x22: c4ceb9fe1a85ec53
[   89.296869] x21: 0000000000000000 x20: 0000ffff96a5c718
[   89.302156] x19: 0000ffff96861080 x18: f2cbd570f7c2a5bc
[   89.307846] x17: 0000ffff96f77b00 x16: 0000ffff9747b180
[   89.313315] x15: 6ea20d5924df197f x14: 7eb9c770a266746c
[   89.318827] x13: 8d6e6f1d0b4218a5 x12: 0000000000000000
[   89.324372] x11: 0000000000000001 x10: 0000000000000000
[   89.329813] x9 : ffffffff96861000 x8 : 0000000000000000
[   89.335308] x7 : 0000000000003e90 x6 : 0000000000000001
[   89.340765] x5 : 0000ffff96a5c700 x4 : ffffffff96861000
[   89.346284] x3 : 0027ffff96861000 x2 : 0000000000000000
[   89.351478] x1 : 0000ffff9747a000 x0 : ffffffff96861000
Segmentation fault (core dumped)


The output is similar when attempting to execute any of the other executables that were put into /usr/bin by mariadb.

redfish on IRC confirmed that a similar-looking crash occurs with aarch64 on the RPi3.
Last edited by jernst on Thu Oct 26, 2017 10:02 pm, edited 3 times in total.
jernst
 
Posts: 47
Joined: Tue Aug 20, 2013 4:22 pm
Location: Silicon Valley

Re: mariadb stopped working on EspressoBIN

Postby jernst » Fri Oct 20, 2017 11:40 pm

1. This may be a jemalloc problem. I installed nghttp2, which also depends on jemalloc, and it crashes in a similar manner, while other apps appear to work fine.

2. Rebuilding jemalloc in the current version does not change things.

3. Downgrading jemalloc to 1:5.0.0.-1 does not change things either.
jernst
 
Posts: 47
Joined: Tue Aug 20, 2013 4:22 pm
Location: Silicon Valley

Re: SOLVED: mariadb stopped working aarch64 (EspressoBIN, RP

Postby jernst » Thu Oct 26, 2017 10:02 pm

Was solved by applying a patch to jemalloc, which @leming put into the main repos.
jernst
 
Posts: 47
Joined: Tue Aug 20, 2013 4:22 pm
Location: Silicon Valley


Return to ARMv8

Who is online

Users browsing this forum: No registered users and 3 guests