usb ports not functioning after update

This forum is for topics dealing with problems with software specifically in the AArch64 repo.

usb ports not functioning after update

Postby GrimAce » Mon Dec 14, 2020 2:23 am

Updated with -Syu now my device has no usb ports detected at the login greeter,
so SSH into it tried lsusb nothing, lsblk nope, blkid not a usb.
have tried editing mkinitcpio added modules pcie_brcmstb and xhci_hcd
then ran after
mkinitcpio -P
tried adding this to config.txt
dtoverlay=dwc2,dr_mode=peripheral
thought maybe changing the usb driver might get it working
ran dmesg saw a few failures one around udev looking to mount a mmcblk0p2 well this device root system is mmcblk1p2
tried changing fstab, boot.txt cmdline.txt to the same as what udev looks for mmcblk0p2
mkinitcpio -P
tried reinstalling the kernel with
sudo pacman -Sy linux


nothing seams to be working it maybe because this file system and boot folder are on a MicroSd card with the uboot update has the computer looking out the ports for a usb file system this process times out then it wont mount another thing
Last edited by GrimAce on Tue Dec 15, 2020 2:56 am, edited 1 time in total.
GrimAce
 
Posts: 2
Joined: Mon Nov 09, 2020 1:17 am

Re: usb ports not functioning after update

Postby rahb » Mon Dec 14, 2020 11:55 am

I too am having an issue where the USB ports are no longer working after updating to 5.8.9-2-ARCH on my RPi 4B. I had initially fixed the USB issues by following the instructions to grab the correct device tree blobs from https://github.com/raspberrypi/firmware ... aster/boot, but as soon as I run:

Code: Select all
pacman -Syu

and reboot, USB fails to work.

Browsing through my kernel messages, I see some error messages related to xhci_hcd:

Code: Select all
[    9.597900] xhci_hcd 0000:01:00.0: xHCI Host Controller
[    9.598065] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 1
...
[   19.598099] xhci_hcd 0000:01:00.0: can't setup: -110
[   19.598183] xhci_hcd 0000:01:00.0: USB bus 1 deregistered
[   19.598399] xhci_hcd 0000:01:00.0: init 0000:01:00.0 fail, -110
[   19.598478] xhci_hcd: probe of 0000:01:00.0 failed with error -110

It looks like xhci_hcd cannot set up the USB bus for some reason. However, I am not having the same udev issue OP mentioned. I have a feeling it’s a .dtb issue as before, but I haven’t found a .dtb that fixes it. The most recent .dtbs in the repo linked earlier do not solve the issue for me.
rahb
 
Posts: 2
Joined: Mon Dec 14, 2020 11:27 am

Re: usb ports not functioning after update

Postby TheBattleWolf » Mon Dec 28, 2020 3:31 pm

Hello,

I have the same issue, previously i could fix this by copying the upstream boot loader. This time it doesn't seem to work.
TheBattleWolf
 
Posts: 1
Joined: Mon Dec 28, 2020 3:00 pm

Re: usb ports not functioning after update

Postby GrimAce » Wed Dec 30, 2020 2:28 am

Since my last post ive followed the strategy offered in these posts on the forum
viewtopic.php?f=65&t=14734&start=30 Fincer of using the Ubutnu boot files for dtb
as well as pierrec viewtopic.php?f=65&t=14734&start=20 strategy of dtb, start.elf and dat
none worked for me i tried with files from both manjaro and ubuntu nothing worked.

i did add module xhci_hcd to my mkinitcpio file but where do i get the firmware for that from ? ive tried searching the internet cannot find a led please share if you know thanks in advance, for now i have two sd cards one that has the updated kernel trying to hack a fix and on the other is before the update.
GrimAce
 
Posts: 2
Joined: Mon Nov 09, 2020 1:17 am

Re: usb ports not functioning after update

Postby uhhyeahbret » Fri Jan 15, 2021 5:39 pm

I am running into the same issue.

Raspi4 8GB model. USB doesn't work. Network works until I run pacman -Syu.

I did find a fix for the network here: viewtopic.php?f=65&t=14672&start=30#p65327

But copying the latest bcm2711-rpi-4-b.dtb to /boot no longer seems to fix USB.

Anyone have a more recent fix for USB?

Are there plans to incorporate fixes into the base aarch64 image for these raspi4 issues?
uhhyeahbret
 
Posts: 1
Joined: Thu Sep 03, 2015 11:10 am

Re: usb ports not functioning after update

Postby djselbeck » Mon Jan 18, 2021 5:49 am

I have the same problem and identified that it started with commit https://github.com/raspberrypi/firmware ... 8a7584cfd7 which got pulled in with a recent update to `raspberrypi-bootloader` I use mainline kernel and git uboot and both fail to init USB currently.

But I also found a ticket https://github.com/raspberrypi/firmware/issues/1518 and a patch series for uboot at least: http://u-boot.10912.n7.nabble.com/PATCH ... 35983.html

For the time being I downgraded my raspberrypi-bootloader to commit 08ed7a0c9ad4d9db559aaec462520ab435c7ce1c which is the last working.
djselbeck
 
Posts: 1
Joined: Fri Jan 15, 2021 1:37 pm

Re: usb ports not functioning after update

Postby graysky » Mon Jan 18, 2021 12:18 pm

Unless you have specific reasons to keep using the vanilla kernel provided by linux-aarch64, try the aarch64 linux-raspberrypi4 kernel and see if your problem goes away. It is currently in the official repos providing the rpi-5.4.y branch but if you want the latest based on rpi-5.10.y, see this post.
graysky
 
Posts: 933
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000


Return to ARMv8

Who is online

Users browsing this forum: No registered users and 3 guests