[Raspberry Pi 4] KODI does not start

This is for ARMv8 based devices

[Raspberry Pi 4] KODI does not start

Postby doragasu1 » Sat Sep 07, 2019 7:53 pm

I have installed kodi-rbp4 on my RaspberryPi 4, enabled the service and started it, but it is not starting.

On boot, or each time I try manually starting the service, this error is printed 3 times on the screen:
Code: Select all
ERROR: Unable to start the GUI. Exiting
.

I have tried manually starting kodi in standalone mode with the following command, with the same result:
Code: Select all
$ WINDOWING=gbm kodi --standalone --debug


The crash log shows among other info, the following:
Code: Select all
2019-09-07 18:59:16.952 T:2977251344   ERROR: CWinSystemGbm::InitWindowSystem - failed to initialize Atomic DRM
2019-09-07 18:59:16.952 T:2977251344   DEBUG: CDRMUtils::DestroyDrm - failed to drop drm master: Bad file descriptor
2019-09-07 18:59:16.954 T:2977251344   ERROR: CWinSystemGbm::InitWindowSystem - failed to initialize Legacy DRM
2019-09-07 18:59:16.954 T:2977251344   DEBUG: CDRMUtils::DestroyDrm - failed to drop drm master: Bad file descriptor
2019-09-07 18:59:16.956 T:2977251344   ERROR: CWinSystemGbm::InitWindowSystem - failed to initialize off screen DRM
2019-09-07 18:59:16.956 T:2977251344   FATAL: CApplication::Create: Unable to init windowing system
2019-09-07 18:59:16.956 T:2977251344  NOTICE: Stopping player
2019-09-07 18:59:16.956 T:2977251344  NOTICE: Storing total System Uptime


Why it is not starting? I have installed neither X nor pulseaudio, but they are not required to use it as standalone with GBM, as far as I know. Maybe there is some kind of problem with the DRM layer?
doragasu1
 
Posts: 78
Joined: Sun Jun 03, 2012 3:52 pm

Re: [Raspberry Pi 4] KODI does not start

Postby graysky » Sat Sep 07, 2019 9:10 pm

Post your /boot/config.txt

I suspect you omitted what pacman told you: https://github.com/graysky2/PKGBUILDs/b ... nstall#L10
graysky
 
Posts: 516
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000

Re: [Raspberry Pi 4] KODI does not start

Postby doragasu1 » Sun Sep 15, 2019 3:53 pm

Got another SD card, made a new alarm install from scratch, added the following to /boot/config.txt:

Code: Select all
gpu_mem=320
dtoverlay=vc4-fkms-v3d
dtparam=audio=on


And Kodi starts. But doing the same on 3yo install does not work...
doragasu1
 
Posts: 78
Joined: Sun Jun 03, 2012 3:52 pm

Re: [Raspberry Pi 4] KODI does not start

Postby graysky » Sun Sep 15, 2019 6:33 pm

doragasu1 wrote:Got another SD card, made a new alarm install from scratch, added the following to /boot/config.txt:

Code: Select all
gpu_mem=320
dtoverlay=vc4-fkms-v3d
dtparam=audio=on


And Kodi starts. But doing the same on 3yo install does not work...


That makes no sense to me, but you seem to have everything working now so rock on.
graysky
 
Posts: 516
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000


Return to ARMv8 Devices

Who is online

Users browsing this forum: No registered users and 1 guest