Samsung Chromebook Plus Install Fails

This is for ARMv8 based devices

Samsung Chromebook Plus Install Fails

Postby Adonnen » Thu Apr 22, 2021 2:52 pm

Was going to title that the install was broken, but I'm a complete newbie, so that might be a bit pretentious. I've been trying to use arch linux on my chromebook with a desktop environment, but I can't the install to properly boot. Some problems I've been having with the provided instructions (apologize for my bad forum etiquette and organization): ... ebook-plus
1. Tar/BSDtar - the instructions use the tar command, which throws some nonfatal errors in crosh shell, but I read elsewhere that the bsdtar command should be used, and it extracts without the errors. Is this necessary/correct?
2. With the default tarball ( ... est.tar.gz), the kernel is too large. There are some other posts from last year about this, but following the instructions, copying the kernel brings up a storage error, leaving it incomplete and unbootable (using control-u). I think it is a 32 mb limit. I saw some fixes for users who were updating their installs, but I couldn't really understand how to apply/patch to the install.
3. Trouble with gru-latest - with the tarball ( ... est.tar.gz) used with the Asus Chromebook Flip C101PA ( ... lip-c101pa), which has the same rockchip cpu and gpu, control-U works, but I get an unchanging blank screen and have to shut down and restart chrome os with the power button. I checked vmlinux.kpart, which was 21.9 mb, and I don't get the size error with the dd command. I don't know if it's frozen, or something's wrong with the display driver, but from other posts I've seen, it's probably the latter, hence the different tarballs for the Asus and Samsung.
Maybe the kernel trimming was only applied to the Asus and hasn't been for the Samsung download? I'm sorry, but I'm stumped. I also had some trouble with the USB, and only ended up passing control-u boot with my microsd, but I think that's down to using the default tarball.
Posts: 2
Joined: Thu Apr 22, 2021 2:33 pm

Re: Samsung Chromebook Plus Install Fails

Postby Adonnen » Mon Apr 26, 2021 3:22 pm

UPDATE: I managed to boot into Arch Linux Arm by downloading an old build from (, ArchLinuxARM-aarch64-chromebook-latest.tar.gz). The font was tiny but readable due to high res display, and I had a small problem with connecting to wifi (solved with Immediately after
Code: Select all
pacman-key --init
pacman-key --populate archlinuxarm
, I tried running
Code: Select all
pacman -Syu

The first time through, I agreed to upgrade the kernel and rebooted to the same blank screen as with gru (ctrl-u doesn't go black but upon boot, nothing happens). I then went through the install again. I had no wifi troubles, but after upgrading, refusing the kernel upgrade, and rebooting, same black screen. I don't know much about Arch, so I'm not sure if it upgraded the kernel anyways, or what else is at play. Is there any way to figure out what's causing this and stop it? Does it involve building the kernel myself? I want to get through the upgrade and then install x-org and a graphical desktop.
Posts: 2
Joined: Thu Apr 22, 2021 2:33 pm

Re: Samsung Chromebook Plus Install Fails

Postby droptable » Sun May 02, 2021 1:31 pm

Had the same problem while trying to flash it onto a USB stick using the instructions from here.

First it failed to dd the kernel partition:
Code: Select all
$ dd if=root/boot/vmlinux.kpart of=/dev/sdf1
dd: writing to '/dev/sdf1': No space left on device
65537+0 records in
65536+0 records out
33554432 bytes (34 MB, 32 MiB) copied, 28,3307 s, 1,2 MB/s

Then I doubled the partition size to 64MiB after which dd ran without errors, but it would not boot for some reason and beeped when I pressed CTRL+U to boot from my USB stick.

I also verified the kernel partition to see if something is wrong with it:
Code: Select all
$ vbutil_kernel --verify /dev/sdf1 --verbose
Key block:
  Signature:           ignored
  Size:                0x4b8
  Flags:               7  !DEV DEV !REC
  Data key algorithm:  4 RSA2048 SHA256
  Data key version:    1
  Data key sha1sum:    d6170aa480136f1f29cf339a5ab1b960585fa444
  Size:                0xfb48
  Header version:      2.2
  Kernel version:      1
  Body load address:   0x100000
  Body size:           0x2010000
  Bootloader address:  0x210f000
  Bootloader size:     0x1000
  Flags          :       0x0
Body verification succeeded.
console=tty0 console=ttyS2,115200n8 earlyprintk=ttyS2,115200n8 init=/sbin/init root=PARTUUID=%U/PARTNROFF=1 rootwait rw noinitrd
Posts: 1
Joined: Wed Apr 11, 2018 11:00 am

Re: Samsung Chromebook Plus Install Fails

Postby 1peter10 » Sun Jun 13, 2021 4:53 pm

I have run into the same issue while running the mainline kernel "linux-aarch64-chromebook" on my ASUS C101PA, I have had issues with newer kernel releases than 5.7. I guess that 32MB maybe a hard limit by the ChromeOS bootloader for the kernel partition, so changes need to happen to the kernel config to get a smaller vmlinux.kpart again. The linux-aarch64-rc-chromebook image is small enough, sadly it does not seem to work for me either.
Posts: 2
Joined: Tue Nov 14, 2017 5:04 pm

Return to ARMv8 Devices

Who is online

Users browsing this forum: No registered users and 2 guests