Can't bring up wlan0

This is for ARMv8 based devices

Can't bring up wlan0

Postby trustnt » Thu Jan 20, 2022 9:32 am

I'm using a Raspberry Pi 3 Model B and using the aarch64 image, the kernel version is 5.16.1-1-aarch64-ARCH.

This is the command I used to bring it up
Code: Select all
sudo ip link set dev wlan0 up
but when I look at the output of
Code: Select all
ip a
this is the output for wlan0, it still says it's down and I can't use it with hostapd
Code: Select all
wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
trustnt
 
Posts: 12
Joined: Wed Sep 22, 2021 4:03 pm

Re: Can't bring up wlan0

Postby mactroneng » Sat Jan 22, 2022 9:29 pm

Just joined the forum to report this + video not being detected properly any longer, but then on my fresh install (see below), WiFi is working....

I did a fresh install and everything works fine with the software that comes with installation tarball, but upon updating is when I get problems. WiFi, however, works with the fresh install + update but video detection still does not.

Edit: Unfortunately I had cleared my package cache not long ago so I don't have much earlier packages to test with downgrading
mactroneng
 
Posts: 2
Joined: Sat Jan 22, 2022 8:54 pm

Re: Can't bring up wlan0

Postby graysky » Sat Jan 22, 2022 10:06 pm

@trustnt - Updates to the kernel you're running have been made to accept compressed firmware files have been pushed since you posted. Update your system.

@mactroneng - No idea what hardware/kernel you're running. Knee-jerk advice is same same as I gave above.
graysky
 
Posts: 1374
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000

Re: Can't bring up wlan0

Postby mactroneng » Sun Jan 23, 2022 3:18 am

Raspberry Pi 4B 4GB

Latest system update a did was a couple hours ago. WiFi was working but video detection is not proper using HDMI on three different screens tested. aarch64 Kernel 5.16.2 (not the rpi one)
mactroneng
 
Posts: 2
Joined: Sat Jan 22, 2022 8:54 pm

Re: Can't bring up wlan0

Postby graysky » Sun Jan 23, 2022 4:08 am

I don't know about linux-aarch64 but linux-rpi should work...
graysky
 
Posts: 1374
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000


Return to ARMv8 Devices

Who is online

Users browsing this forum: No registered users and 3 guests