aarch64 on Raspberry Pi 4 doesn't reconnect after reboot

Ask questions about Arch Linux ARM. Please search before making a new topic.

aarch64 on Raspberry Pi 4 doesn't reconnect after reboot

Postby pizie » Tue Sep 15, 2020 2:29 pm

Hi everyone.

I am new to posting in forums so apologies if this doesn't follow rules/formats etc., or doesn't have the correct info...

In essence my problem is that when I 'sudo reboot' my Raspberry Pi 4 from a remote terminal via ssh the router doesn't see it and assign an IP address when it comes back up.

I'm trying to teach myself a little bit of Linux admin. As I build the RP4 over time I have been doing 'sudo reboot'. This was fine up until recently; however, I was struggling big time to establish a wifi connection with my RP4. In desperation I ditched everything and tried Raspberry Pi OS 32B. That didn't work either so at that point I gave up - I was happy to work with a wired connection anyway - and went back to aarch64. Ever since then I have been experiencing this 'sudo reboot' problem with RP4 running aarch64. The only thing that seems to work is if I reboot the router and then reboot the RP4 (whilst connected via ethernet).

The problem started off very intermittent, but yesterday I began having a 100% 'sudo reboot' FAIL rate. That is, being forced to reboot the router every time in order to get a connection.

I've tried exchanging ethernet cables, connecting the RP4 to the network via an extender, switching off the extender and turning on and off the RP4 at the wall socket; nothing.

As a test I went back to Raspberry Pi OS 32B and rebooted that many times in succession with a 100% 'sudo reboot' SUCCESS rate - i.e. a connection without having to cycle the router. Back immediately to aarch64 and guess what... 100% 'sudo reboot' FAIL rate!

Any ideas? It's so frustrating I'm starting to believe in gremlins...


[Edit]
It got so bad that couldn't connect to my RP4 at all. I tried rebuilding the SD according to https://archlinuxarm.org/platforms/armv8/broadcom/raspberry-pi-4 on a different and possibly newer machine and low and behold it connected and rebooted most of the time. Disconnecting power from the RP4 solved the times it didn't work. Interestingly, I noticed that it had a different IP address...
pizie
 
Posts: 1
Joined: Tue Sep 15, 2020 1:38 pm

Return to User Questions

Who is online

Users browsing this forum: No registered users and 2 guests