[SOLVED] Umounts happen automatically

Ask questions about Arch Linux ARM. Please search before making a new topic.

[SOLVED] Umounts happen automatically

Postby TheChosenOne » Wed Dec 02, 2020 9:49 pm

I have two devices mounted. An external SSD and a USB stick.
After a few hours, they both get umounted. I don't know why. I've checked journalctl, but there is nothing unusual logged. I've tried to mount the USB stick without the SSD plugged in, and the same happens, so it's not a power issue.
I've updated Arch without avail. I suspect this is a hardware problem :(
I'm running ARMv7 on a Pi 3B.

Anyone else having the same issue?
Last edited by TheChosenOne on Sat Jan 09, 2021 12:08 pm, edited 1 time in total.
TheChosenOne
 
Posts: 9
Joined: Sun Mar 31, 2019 7:04 pm

Re: Umounts happen automatically

Postby TheChosenOne » Sat Jan 09, 2021 12:08 pm

So I bought a new Pi (Pi 4). Deployed everything. Same problem!

Turns out if you mount in an ecryptfs encrypted folder, things get unmounted after a while. The solution is to mount outside the ecryptfs folder (eg in /mnt) and create a soft link. In sshfs, you can use -o follow_symlinks to make sure it still works when you mount the folder on your local pc.

After the latest upgrades, everything is fine again, even on the old pi. So, it was not a hardware problem. Case closed.
TheChosenOne
 
Posts: 9
Joined: Sun Mar 31, 2019 7:04 pm


Return to User Questions

Who is online

Users browsing this forum: No registered users and 4 guests