IPV6 settings are overwritten [solved]

Ask questions about Arch Linux ARM. Please search before making a new topic.

IPV6 settings are overwritten [solved]

Postby Lolek » Thu Oct 20, 2016 7:33 am

Hi Folks,

I am new to ArchLinux and have a little problem with the configuration.
I have created a file xx-disable-ipv6.conf under /etc/sysctl.d.

net.ipv6.conf.all.disable_ipv6=1
net.ipv6.conf.eth0.disable_ipv6=1
net.ipv6.conf.wlan0.disable_ipv6=1

The settings for wlan0 and all are accepted, only with eth0 a cat points to the corresponding file the value 0. If I set the [Match] section to /etc/systemd/network/eth0.network, the value remains set to 1.
How can I prevent the value from being overwritten?

Thanks for all replies :)
Greeting Bolek
Last edited by Lolek on Fri Oct 21, 2016 7:00 pm, edited 1 time in total.
Lolek
 
Posts: 3
Joined: Thu Oct 20, 2016 7:04 am

Re: IPV6 settings are overwritten

Postby WarheadsSE » Thu Oct 20, 2016 2:20 pm

Are you using DHCP? If so, did you set the DHCP= line to IPv4
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6730
Joined: Mon Oct 18, 2010 2:12 pm

Re: IPV6 settings are overwritten

Postby Lolek » Fri Oct 21, 2016 5:51 pm

Hello WarheadsSE

thanks for the answer.

Yes, I use DHCP and the line is DHCP = ipv4.

I think this behavior is new. I had installed my first PI with Archlinux two months ago. This Raspberry worked at the beginning until I made an update (pacman -Syu).
Lolek
 
Posts: 3
Joined: Thu Oct 20, 2016 7:04 am

Re: IPV6 settings are overwritten

Postby Lolek » Fri Oct 21, 2016 6:58 pm

I have added a line "Link Local Addressing = no". Now it's working. :D
Lolek
 
Posts: 3
Joined: Thu Oct 20, 2016 7:04 am


Return to User Questions

Who is online

Users browsing this forum: No registered users and 2 guests