How can I disable LVM at startup, using systemd?

Ask questions about Arch Linux ARM. Please search before making a new topic.

How can I disable LVM at startup, using systemd?

Postby alpery » Tue Nov 15, 2016 6:58 pm

Hello,

I am trying to build a very simple file server on Raspberry Pi using Arch Linux ARM

I am using LVM2. I have installed using pacman.

However, some PVs will not be available at startup. Another script will be able to connect external USB disks over USB port physically if it is needed.

If suitable PVs are available at startup, LVM forms and makes available VGs automatically. I don't want this. I want to take control over. I will write scripts for other tasks and I want to make enable VGs whenever I want by calling commands of LVM. How can I disable this behaviour of LVM? Should I disable by configuring systemd? I am very new to Arch Linux and didn't understand systemd entries of LVM so much.

Thank you.

P.S. Previously I have asked this question on Arch Linux forum but a moderator thought that I should ask on this forum since I am running ARM port! https://bbs.archlinux.org/viewtopic.php?id=219598
alpery
 
Posts: 4
Joined: Sat Sep 21, 2013 5:05 pm

Re: How can I disable LVM at startup, using systemd?

Postby graysky » Tue Nov 15, 2016 8:44 pm

Dunno for sure but it seems that there is a socket enabled by the package:
Code: Select all
pacman -Ql lvm2| grep sock
vm2 /usr/lib/systemd/system/lvm2-lvmetad.socket
lvm2 /usr/lib/systemd/system/sysinit.target.wants/lvm2-lvmetad.socket


Not sure what it does but I do not see any services or timers enabled by default[/code]
graysky
 
Posts: 356
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000


Return to User Questions

Who is online

Users browsing this forum: No registered users and 3 guests