Error generating UTF-8 locale

Ask questions about Arch Linux ARM. Please search before making a new topic.

Re: Error generating UTF-8 locale

Postby jedie2 » Thu Dec 22, 2011 11:13 pm

slycat wrote:I get everything to generate properly. Originally i thought it was due to a command in the /usr/sbin/locale-gen
Code: Select all
[ -f $LOCALEGEN -a -s $LOCALEGEN ] || exit 0;

# Remove all old locale dir and locale-archive before generating new
# locale data.
rm -rf /usr/lib/locale/* || true


Because of this, making the UTF-8 file at the end will fix it. Now I can run glibc update (required utf-8 to generate)
Still can't run gcc-libs update thought :?


I have a equal issuse:
Code: Select all
[root@PLX7820 ~]# locale-gen
Generating locales...
  de_DE.UTF-8...cannot map archive header: Invalid argument



I changed my locale-gen from this:
Code: Select all
de_DE.UTF-8 UTF-8
de_DE ISO-8859-1
de_DE@euro ISO-8859-15
#en_US.UTF-8 UTF-8
#en_US ISO-8859-1

to this:
Code: Select all
de_DE@euro ISO-8859-15
de_DE ISO-8859-1
de_DE.UTF-8 UTF-8
#en_US.UTF-8 UTF-8
#en_US ISO-8859-1


But this didn't fix it:
Code: Select all
[root@PLX7820 ~]# locale-gen
Generating locales...
  de_DE.ISO-8859-15@euro... done
  de_DE.ISO-8859-1... done
  de_DE.UTF-8...cannot map archive header: Invalid argument


The error comes on my http://www.mikrocontroller.net/articles/P89626 NAS, but curious: Same settings works on my GoFlexHome! Any idea?
jedie2
 
Posts: 18
Joined: Wed Dec 14, 2011 3:09 pm

Re: Error generating UTF-8 locale

Postby WarheadsSE » Thu Dec 22, 2011 11:32 pm

It is an issue related to the ox820 kernel. :)
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6804
Joined: Mon Oct 18, 2010 2:12 pm

Re: Error generating UTF-8 locale

Postby jedie2 » Wed Dec 28, 2011 2:48 pm

WarheadsSE wrote:It is an issue related to the ox820 kernel. :)

Exist a official bug report for this? Does anyone work on this?
jedie2
 
Posts: 18
Joined: Wed Dec 14, 2011 3:09 pm

Re: Error generating UTF-8 locale

Postby WarheadsSE » Wed Dec 28, 2011 2:50 pm

I found a way around this once, but I cannot remember where.

I will have to see if this still exists in our 3.1 kernel
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
WarheadsSE
Developer
 
Posts: 6804
Joined: Mon Oct 18, 2010 2:12 pm

Previous

Return to User Questions

Who is online

Users browsing this forum: No registered users and 1 guest