Help preconfiguring systemd service on RPi2

Ask questions about Arch Linux ARM. Please search before making a new topic.

Help preconfiguring systemd service on RPi2

Postby skgucek » Tue Jun 06, 2017 8:45 pm

I am trying to flash archARM on RPi2 SD card, for flashing I am using x86_64 arch on a laptop. I don't have a HDMI screen or keyboard therefore I have to get configuration absolutely right so that RPi2 succesfully connects on eth0 and I can SSH to it.

The problem is that I live in a student dorm where ethernet is secured with IEEE802.1X. The RPi2 image is preconfigured to try to autoconnect on eth0:

Code: Select all


which by itself won't connect succesfully as it cannot authenticate on. But I added

Code: Select all

and put the certificate in /etc (temporarily until I figure out a better location). USERNAME & PASSWORD are of course just blanked out for security purposes. Now the only thing which I would have to do is run:

$ systemctl enable wpa_supplicant-wired@eth0

and then it would succesfully connect on boot, as this service would authenticate eth0.

... but I can't do that, as I don't have a HDMI screen and/or keyboard. The only thing I CAN do is edit the contents of RPi2's SD card on a x86_64 arch laptop.

How can I enable this service by hand, without systemctl?
Posts: 1
Joined: Tue Jun 06, 2017 8:18 pm

Re: Help preconfiguring systemd service on RPi2

Postby WarheadsSE » Tue Jun 06, 2017 9:55 pm

Find the [Install] section of the wpa_supplicant-wired@.service file, an manually symlink wpa_supplicant-wired@.service to wpa_supplicant-wired@eth0.service to the appropriate folder in /etc/systemd/system/
Core Developer
Remember: Arch Linux ARM is entirely community donation supported!
Posts: 6804
Joined: Mon Oct 18, 2010 2:12 pm

Return to User Questions

Who is online

Users browsing this forum: No registered users and 2 guests