[SOLVED]system upgrade breaks pacman in libstdc++.so.6.0.23

Ask questions about Arch Linux ARM. Please search before making a new topic.

[SOLVED]system upgrade breaks pacman in libstdc++.so.6.0.23

Postby koeleco » Tue Jun 13, 2017 6:33 am

Hey!

I was wondering if somebody could give me a push in the right direction with the following:

I performed a full system upgrade with:
Code: Select all
pacman -Syu

After the successful upgrade pacman throws the error:
Code: Select all
[xxx@xxx log]$ pacman
pacman: /usr/lib/libstdc++.so.6: unsupported version 0 of Verdef record
pacman: /usr/lib/libstdc++.so.6: unsupported version 0 of Verdef record
pacman: /usr/lib/libstdc++.so.6: unsupported version 0 of Verdef record
pacman: error while loading shared libraries: /usr/lib/libstdc++.so.6: unsupported version 0 of Verneed record

I cannot find any errors in the pacman.log, so my best guess is that another package upgraded libstdc++.so.6 and pacman isn't compatible with this version. Furthermore I've noticed that the pacman packages (https://www.archlinux.org/packages/core/x86_64/pacman/) the archlinuxare 'Flagged out-of-date on 2017-06-06'.
Code: Select all
[[xxx@xxx lib]$ file libstdc++.so.6
libstdc++.so.6: symbolic link to libstdc++.so.6.0.23

Does anybody know which version pacman 5.0.1-5 is compatible with? Or have a solution for this?
Note that I'm using a Raspberry Pi 2 with armv7h.

Thank you for reading this!

pacman.log
Code: Select all
[2017-06-12 13:39] [PACMAN] Running 'pacman -Syu'
[2017-06-12 13:39] [PACMAN] synchronizing package lists
[2017-06-12 13:39] [PACMAN] starting full system upgrade
[2017-06-12 13:41] [ALPM] transaction started
[2017-06-12 13:41] [ALPM] upgraded glibc (2.25-1 -> 2.25-2)
[2017-06-12 13:41] [ALPM-SCRIPTLET] Generating locales...
[2017-06-12 13:41] [ALPM-SCRIPTLET] Generation complete.
[2017-06-12 13:41] [ALPM] upgraded binutils (2.28.0-2 -> 2.28.0-3)
[2017-06-12 13:41] [ALPM] upgraded libtasn1 (4.10-1 -> 4.12-1)
[2017-06-12 13:41] [ALPM] upgraded p11-kit (0.23.5-1 -> 0.23.7-1)
[2017-06-12 13:41] [ALPM] upgraded gcc-libs (6.3.1-2 -> 7.1.1-2)
[2017-06-12 13:41] [ALPM] upgraded ncurses (6.0+20170429-1 -> 6.0+20170527-1)
[2017-06-12 13:43] [ALPM] upgraded perl (5.24.1-1 -> 5.26.0-1)
[2017-06-12 13:43] [ALPM] upgraded ca-certificates-mozilla (3.30.2-1 -> 3.31-3)
[2017-06-12 13:43] [ALPM] upgraded diffutils (3.5-1 -> 3.6-1)
[2017-06-12 13:44] [ALPM] upgraded file (5.30-1 -> 5.31-1)
[2017-06-12 13:48] [ALPM] upgraded gcc (6.3.1-2 -> 7.1.1-2)
[2017-06-12 13:48] [ALPM] upgraded perl-error (0.17024-1 -> 0.17024-2)
[2017-06-12 13:49] [ALPM] upgraded libldap (2.4.44-4 -> 2.4.44-5)
[2017-06-12 13:50] [ALPM] upgraded krb5 (1.15-1 -> 1.15.1-1)
[2017-06-12 13:50] [ALPM] upgraded libnghttp2 (1.22.0-1 -> 1.23.1-1)
[2017-06-12 13:50] [ALPM] upgraded git (2.13.0-1 -> 2.13.1-1)
[2017-06-12 13:50] [ALPM] upgraded glib2 (2.52.2+1+gb8bd46bc8-1 -> 2.52.2+9+g3245eba16-1)
[2017-06-12 13:50] [ALPM] upgraded npth (1.4-1 -> 1.5-1)
[2017-06-12 13:50] [ALPM] upgraded libgcrypt (1.7.6-1 -> 1.7.7-1)
[2017-06-12 13:50] [ALPM] upgraded gnutls (3.5.12-1 -> 3.5.13-1)
[2017-06-12 13:50] [ALPM] upgraded sqlite (3.18.0-1 -> 3.19.3-1)
[2017-06-12 13:51] [ALPM] upgraded gnupg (2.1.21-1 -> 2.1.21-3)
[2017-06-12 13:51] [ALPM] upgraded libelf (0.168-1 -> 0.169-1)
[2017-06-12 13:51] [ALPM] upgraded libtool (2.4.6-7 -> 2.4.6-8)
[2017-06-12 13:53] [ALPM] upgraded linux-raspberrypi (4.9.30-1 -> 4.9.31-1)
[2017-06-12 13:54] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2017-06-12 13:54] [ALPM] upgraded nano (2.8.2-1 -> 2.8.4-1)
[2017-06-12 13:54] [ALPM] upgraded nspr (4.14-1 -> 4.15-1)
[2017-06-12 13:55] [ALPM] upgraded nss (3.30.2-1 -> 3.31-3)
[2017-06-12 13:55] [ALPM] upgraded raspberrypi-bootloader (20170515-1 -> 20170609-1)
[2017-06-12 13:55] [ALPM] upgraded raspberrypi-bootloader-x (20170515-1 -> 20170609-1)
[2017-06-12 13:55] [ALPM] upgraded subversion (1.9.5-2 -> 1.9.5-3)
[2017-06-12 13:55] [ALPM] upgraded sudo (1.8.20-1 -> 1.8.20.p2-1)
[2017-06-12 13:55] [ALPM] upgraded texinfo (6.3-1 -> 6.3-2)
[2017-06-12 13:55] [ALPM] upgraded vim-runtime (8.0.0586-2 -> 8.0.0628-1)
[2017-06-12 13:55] [ALPM] upgraded vim (8.0.0586-2 -> 8.0.0628-1)
[2017-06-12 13:56] [ALPM] upgraded wpa_supplicant (1:2.6-5 -> 1:2.6-6)
[2017-06-12 13:56] [ALPM] transaction completed
[2017-06-12 13:56] [ALPM] running '99-linux-raspberrypi.hook'...
[2017-06-12 13:58] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-raspberrypi.preset: 'default'
[2017-06-12 13:58] [ALPM-SCRIPTLET]   -> -k 4.9.31-1-ARCH -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2017-06-12 13:59] [ALPM-SCRIPTLET] ==> Starting build: 4.9.31-1-ARCH
[2017-06-12 14:00] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-06-12 14:00] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-06-12 14:00] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-06-12 14:00] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-06-12 14:00] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-06-12 14:00] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-06-12 14:00] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-06-12 14:00] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-06-12 14:00] [ALPM-SCRIPTLET] ==> WARNING: No modules were added to the image. This is probably not what you want.
[2017-06-12 14:00] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2017-06-12 14:00] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-06-12 14:00] [ALPM] running 'systemd-tmpfiles.hook'...
[2017-06-12 14:00] [ALPM] running 'systemd-update.hook'...
[2017-06-12 14:00] [ALPM] running 'texinfo-install.hook'...
[2017-06-12 14:00] [ALPM] running 'update-ca-trust.hook'...
Last edited by koeleco on Mon Jun 19, 2017 8:19 pm, edited 2 times in total.
koeleco
 
Posts: 2
Joined: Tue Jun 13, 2017 6:25 am

RE: system upgrade breaks pacman in libstdc++.so.6.0.23

Postby koeleco » Mon Jun 19, 2017 7:57 pm

It seems that the update of gcc-libs 7.1.1-2 breaks pacman. This version of gcc-libs has a newer version of a lib file 'libstdc++.so.6.0.23' and pacman throws an error with this version.

What have I done to solve it:
- I've downloaded the 6 version gcc-libs-6.3.1-2-armv7h.pkg.tar.xz and extracted file 'libstdc++.so.6.0.22' from it.
- Copy the file to /usr/lib folder
- Remove symlink to newer version
Code: Select all
rm libstdc++.so.6

- Create a new symlink
Code: Select all
sudo ln -s libstdc++.so.6.0.22 libstdc++.so.6


And it should be fixed.
koeleco
 
Posts: 2
Joined: Tue Jun 13, 2017 6:25 am


Return to User Questions

Who is online

Users browsing this forum: No registered users and 1 guest