Arch on Odroid XU4 with wiringpi2: GPIO 11 Keeps Reverting

Ask questions about Arch Linux ARM. Please search before making a new topic.

Arch on Odroid XU4 with wiringpi2: GPIO 11 Keeps Reverting

Postby Cavadus » Mon Jun 26, 2017 10:07 pm

Title says a lot but I'm currently running Arch on an Odroid XU4. I have a cellular modem attached but I'm having an issue with GPIO 11 (pin #24). It boots high which puts the modem into a reboot sequence. I installed hardkernal's wiringpi2 and it works great. I created a script to run in the boot services which would set the pin to out, then to low, then read it back for logging. My logs indicate that this script is, indeed, setting GPIO 11 to low.

Unfortunately, it refuses to stay low and by the time the boot sequence finishes it's back to high. Additionally, if I run the script after boot it'll set GPIO 11 to low but a few minutes later it's back to high.

Any ideas what the heck keeps setting GPIO 11 to high and how to get make it stay low?
Cavadus
 
Posts: 3
Joined: Mon Jun 26, 2017 10:05 pm

Re: Arch on Odroid XU4 with wiringpi2: GPIO 11 Keeps Reverti

Postby Cavadus » Tue Jun 27, 2017 6:56 pm

The plot thickens a little bit. It turns out the issue is with hardkernel's wiringpi2.

$ gpio export 11 out
gpio: Unable to open GPIO direction interface for pin 11: No such file or directory
Cavadus
 
Posts: 3
Joined: Mon Jun 26, 2017 10:05 pm

Re: Arch on Odroid XU4 with wiringpi2: GPIO 11 Keeps Reverti

Postby Cavadus » Tue Jun 27, 2017 9:19 pm

I just disconnected the pin on the daughter board, tbh. Works fine meow.
Cavadus
 
Posts: 3
Joined: Mon Jun 26, 2017 10:05 pm


Return to User Questions

Who is online

Users browsing this forum: No registered users and 2 guests