BeagleBone Black

Ask questions about Arch Linux ARM. Please search before making a new topic.

BeagleBone Black

Postby nsollars » Mon Sep 04, 2017 6:26 pm

Hi All,

So I get Arch up and running using the 2GB eMMC flash .. I have an 8GB microssd that I would like to put the contents of /usr on.

After attempting this and adding the mmcblk0p1 device to fstab and rebooting this failed as the ssd is not automounted thus init is not found and the boot bails accordingly. I copied back all the files to the eMMC and have a working system.

Any quick pointers as to what I missed would be appreciated

Thanks in advance
nsollars
 
Posts: 4
Joined: Mon Sep 04, 2017 6:14 pm

Re: BeagleBone Black

Postby nsollars » Mon Sep 04, 2017 9:41 pm

Hi all,

So i fixed it, here is the solution ( pretty simple using lsblk -f) ..

UUID=c10b9568-2365-4ca1-9cd3-dd1ed95ec01e /usr ext4 rw,relatime,discard,data=ordered 0 1

So il be able to carry on now.. For anyone interested im using the Beglebone for a robotics project using a pololu maestro ( 24 chan ) controller, which is why I wanted to offload alot to a SD Card since its class 10 @ 8G vs the 2G eMMC.

Also I have the andice labs power cape for this one which should be interesting too.

Nige
nsollars
 
Posts: 4
Joined: Mon Sep 04, 2017 6:14 pm

Re: BeagleBone Black

Postby nsollars » Mon Sep 04, 2017 10:13 pm

Hey all,

Spoke a little too soon, so basically here is what I need.. init and friends are located in /usr/bin with /sbin all symlink'd to said usr/bin.

With out the card being mounted it wont find init .. I think the simplest thing to do is to make /sbin a real directory and copy in the minimal needed to satisfy init / boot ( without kernel panic ) ... so that the sdcard can then be mounted as /usr.

Again any help here would be great..

Regards
Nige
nsollars
 
Posts: 4
Joined: Mon Sep 04, 2017 6:14 pm


Return to User Questions

Who is online

Users browsing this forum: No registered users and 2 guests