[ARMv7h][RPi3B] Kernel 5.10.31-4 no longer SMP PREEMPT

Ask questions about Arch Linux ARM. Please search before making a new topic.

[ARMv7h][RPi3B] Kernel 5.10.31-4 no longer SMP PREEMPT

Postby wgross » Sat Apr 17, 2021 7:44 am

Hi,
I am really a big fan of ARCH Linux both for my PC's my Laptop's and my RaspberryPi's. I constantly keep all machines up to date with what is provided in the official repositories. On the RaspberryPi I work on medium critical Real-Time Applications. Now I recognized that the new packages "... linux-raspberrypi-5.10.31-4-armv7h" use "voluntary preemption" for kernel configuration, which is bad for my application. Therefore I had to downgrade to "linux-raspberrypi-5.4.83-3-armv7h". I really want to avoid that I need to build my own kernel, therefore I would like to know why you made this change and whether you plan to use a "SMP PREEMPT" kernel in the future again.
How can I move this to Forum ARMv7h ?
Or should I consider switching to aarch64, but I need all the overlays stuff ?
Thanks a lot, especially for the fantastic job you do !
wgross
 
Posts: 1
Joined: Sat Apr 17, 2021 7:22 am

Return to User Questions

Who is online

Users browsing this forum: Google [Bot] and 3 guests