Still no Audio support on the OLinuXino MAXI?

This forum is for i.MX233 based devices including the OLinuXino

Still no Audio support on the OLinuXino MAXI?

Postby Landoro » Sat May 16, 2015 1:41 pm

Hello everyone, I've been struggling to get a proper working kernel with audio support. I tried literally every single idea you guys have posted. I'm sharing the kernel oops:


The moment I try to run alsamixer, aplay -l, amixer, the system just freezes and I can't kill those processes!
I really need an explanation for this.

[ 3.790000] mmcblk0: p1 p2
[ 3.830000] mxs-sgtl5000 sound: failed to get mclk
[ 3.840000] mxs-sgtl5000: probe of sound failed with error -22
[ 3.850000] usb 1-1: new high-speed USB device number 2 using ci_hdrc
[ 3.870000] mxs-builtin-audio mxs-builtin-audio: mxs-builtin-codec-dai <-> 80048000.mxs-builtin-cpu-dai mapping ok
[ 4.150000] ALSA device list:
[ 4.150000] #0: mxs-builtin-audio
[ 32.250000] sgtl5000 0-000a: Failed to get mclock: -2
[ 32.330000] i2c 0-000a: Driver sgtl5000 requests probe deferral
[ 32.590000] sgtl5000 0-000a: Failed to get mclock: -2
[ 32.690000] i2c 0-000a: Driver sgtl5000 requests probe deferral
[ 32.790000] sgtl5000 0-000a: Failed to get mclock: -2
[ 32.790000] i2c 0-000a: Driver sgtl5000 requests probe deferral
[ 34.440000] Unable to handle kernel NULL pointer dereference at virtual address 00000004
[ 34.520000] pgd = c2f4c000
[ 34.650000] [00000004] *pgd=42f3d831, *pte=00000000, *ppte=00000000
[ 34.650000] Internal error: Oops: 17 [#1] PREEMPT ARM

Rado
Landoro
 
Posts: 1
Joined: Fri May 15, 2015 1:40 pm

Return to Freescale i.MX233

Who is online

Users browsing this forum: No registered users and 0 guests