[SOLVED] Partial read 4 bytes on /dev/lirc0 Rasp 3

This forum is for topics dealing with problems with software specifically in the AArch64 repo.

[SOLVED] Partial read 4 bytes on /dev/lirc0 Rasp 3

Postby Fujitus » Mon Aug 22, 2016 12:13 pm

Hey , I try to install lirc on my Raspberry 3 but every time I try to map my remote the encoding byte is diffrent (16, 52, 64, or 128 )

I try to install lirc by folowing this blogs
http://buzzthisnow.com/ir-remote-with-l ... archlinux/
http://ukonline2000.com/?p=296

And when I use "mode2 -d /dev/lirc0" to display the remote values it's tell me "Partial read 4 bytes on /dev/lirc0"

I try with diffrents remote and I got exactly the same problem :oops:

If you have any ideas let my know :)
Last edited by Fujitus on Tue Aug 23, 2016 8:59 am, edited 1 time in total.
Fujitus
 
Posts: 5
Joined: Mon Aug 22, 2016 12:03 pm

Re: Partial read 4 bytes on /dev/lirc0 Rasp 3

Postby moonman » Mon Aug 22, 2016 7:57 pm

There is something wrong with later versions of lirc on rpi.
Use this package and put it into IgnorePkg list in pacman.conf so it doesn't get updated.
http://tardis.tiny-vps.com/aarm/package ... pkg.tar.xz
Pogoplug V4 | GoFlex Home | Raspberry Pi 4 4GB | CuBox-i4 Pro | ClearFog | BeagleBone Black | Odroid U2 | Odroid C1 | Odroid XU4
-----------------------------------------------------------------------------------------------------------------------
[armv5] Updated U-Boot | [armv5] NAND Rescue System
moonman
Developer
 
Posts: 3314
Joined: Sat Jan 15, 2011 3:36 am

[SOLVED] Re: Partial read 4 bytes on /dev/lirc0 Rasp 3

Postby Fujitus » Tue Aug 23, 2016 8:58 am

thank you moonman it's working perfectly :D :D
Fujitus
 
Posts: 5
Joined: Mon Aug 22, 2016 12:03 pm


Return to ARMv8

Who is online

Users browsing this forum: No registered users and 1 guest