Odroid-Xu4 unstable shared network connection

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

Odroid-Xu4 unstable shared network connection

Postby jbodhorn » Mon Nov 13, 2017 3:25 am

My laptop doesn't have ethernet and I finally got a powered usb 3 hub with ethernet adapter to speed up transfers of large files. I use an Odroid-Xu4 running Arch as a file server and it's set up to share it's internet connection but I mainly use it for transferring large files. I have samba, nfs, sftp, dnsmasq, and iptables set up, I use netctl to set up my ethernet adapters. Internet connection sharing has worked fine for a while, it's pretty quick too, this is the first time I've had an issue. My Odroid is connected to my router through the on-board ethernet and I'm sharing the connection through a usb 3 ethernet adapter, the ethernet adapter is plugged into a powered usb 3 hub.

Today when I got my usb 3 ethernet adapter I plugged into the odroid's shared connection and tried to send a file to it for later use, I was transferring a movie file. My shared internet connection was working fine, I used it to download the movie I was transferring to the odroid. Every time I tried to send the movie to the odroid it would drop connection and the transfer would fail. I probably would have had to restart dnsmasq, iptables, and possibly netctl to get my network connection back, so it was easier to just reboot the odroid to fix the dropped connection.

I've tried transferring through both sftp(I use filezilla as the client in Windows 10 and Arch Linux on my laptop) and samba and it's the same result, failed transfer and dropped internet connection. I dual boot my laptop, I tried transferring through both windows 10 and Arch Linux. I wanted to make sure it wasn't an issue with the new ethernet adapter so I plugged into the router and had no problem transferring the file. It's only when I transfer directly to the odroid through it's shared connection

I've used the shared connection to transfer large files many times with no issue, but I've never gotten speeds as fast as today before the connection dropped. Our router/modem is old and crappy and I was getting nearly 40mb/s, when connected directly to the odroid's shared connection it was going much faster before it dropped. Windows 10 gave this error code 0x8007003b when transferring through samba. I'm looking into the error code, but I'm guessing the issue is on the odroid end of things.

I found it weird that transfers are fine through the router/home network, but not when the laptop and odroid are directly connected. Could this be a buffer issue, maybe a power issue on the odroid side? I'm not quite sure where to start looking for answers so I'm starting with the windows error code and this post, any suggestions would be appreciated
jbodhorn
 
Posts: 40
Joined: Wed Dec 16, 2015 2:22 am

Re: Odroid-Xu4 unstable shared network connection

Postby jbodhorn » Tue Nov 14, 2017 12:59 pm

I've been doing a bit more testing and I only have the issue when sending files to my odroid. I can download files from the odroid through the shared connection just fine. It's only uploading that I have this issue and so far it's only when sending from my laptop, it's a lenovo yoga 12
jbodhorn
 
Posts: 40
Joined: Wed Dec 16, 2015 2:22 am


Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 2 guests