[Solved] rpi 4 USB boot?

This is for ARMv8 based devices

[Solved] rpi 4 USB boot?

Postby spirit » Tue Sep 15, 2020 6:33 am

Hi, there! I've successfully installed ArchLinuxARM aarch64 on my rpi
4 with installation guide https://archlinuxarm.org/platforms/armv8/broadcom/raspberry-pi-4, it works perfectly in my SD card, but I have problems with booting form USB. Below is what I do in SSD(with Archarm installed):
1. I flashed the latest release of https://github.com/raspberrypi/rpi-eeprom
2. I edited /etc/fstab file, modified /dev/mmcblk1p1 to /dev/sda1

When I ping my rpi, got no response, so I did the following step:

3. I edited /boot/boot.txt, modified root=PARTUUID
=${uuid} to root=PARTUUID=<my-SSD-uuid>, then run
Code: Select all

When I ping my rpi, got no response. I saw the post https://www.raspberrypi.org/forums/view ... p?t=279470 yesterday, and I did this:

4. Edited /etc/fstab look like this:
Code: Select all
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/sda1  /boot           vfat    defaults          0       1
/dev/sda2  /               ext4    defaults,noatime  0       0

When I plugged in, the rpi still couldn't boot.

Did I do something wrong? What's the correct method to boot Archarm from USB drive?
Last edited by spirit on Tue Sep 15, 2020 10:10 am, edited 1 time in total.
Posts: 2
Joined: Tue May 05, 2020 12:14 pm

Re: rpi 4 USB boot?

Postby Czar » Tue Sep 15, 2020 8:23 am

tl;dr: in current state booting Arch from USB requires manual changes/tweaking.
Posts: 8
Joined: Sat Sep 05, 2020 9:20 am

Re: rpi 4 USB boot?

Postby spirit » Tue Sep 15, 2020 9:52 am

Thank you, Czar! I followed viewtopic.php?f=65&t=14672#p64313, and solve my problem
Hello all,
I managed to boot the official aarch64 rootfs on raspberry pi4 from external SSD without a custom kernel.
To do that I had to:
1) Manually update uboot-raspberrypi to the latest RC (2020.10rc2) to fix "No USB Controller Found" error in U-boot
2) Add pcie_brcmstb into MODULES in /etc/mkinitcpio.conf
3) Rebuild initrd with mkinitcpio -P

If you have /boot on SD card it may be enough to just add pcie_brcmstb in /etc/mkinitcpio.conf and rebuild initrd

For u-boot I just got official PKGBUILD and other files from https://archlinuxarm.org/packages/armv7 ... rypi/files and modified some variables in PKGBUILD:
1) pkgname to uboot-raspberrypi-rc
2) pkgver to 2020.10rc2
3) first checksum int md5sums to 'bae5280c7ce49961c3722fa9019535bf'

Then makepkg -si to build and install it
Posts: 2
Joined: Tue May 05, 2020 12:14 pm

Return to ARMv8 Devices

Who is online

Users browsing this forum: No registered users and 1 guest