netctl-auto@wlan0.service not taking IP address

This forum is for topics dealing with problems with software specifically in the AArch64 repo.

netctl-auto@wlan0.service not taking IP address

Postby optomus » Tue Apr 17, 2018 4:50 am

Hello,
I have set up a few RPis running Archlinux Arm and they have been fully updated as of yesterday. I followed the wiki and obtained wpa_actiond and executed
Code: Select all
enable netctl-auto@wlan0.service
Since I also ran
Code: Select all
disable netctl@MySSID.service
to remove the previous configuration.

Upon powering up all 5 devices connected and if connection was lost they would reconnect. Brilliant. However, all 5 sent out their 4 A.M. email which just after the email
Code: Select all
'ifconfig wlan0 down; sleep 10; ifconfig wlan0 up'
is run but they missed their 7 A.M. email. Investigating a little more and the AP says that they are connected and have an IP, though when trying to ping them they are unreachable.

I powered them down for ~5 minutes and powered them back on. I was able to establish a connection again, logged in, edited a few scripts, tried running the script that executes
Code: Select all
'ifconfig wlan0 down; sleep 10; ifconfig wlan0 up'
with no issues, and left. Remotely I was still able to log into the ones I revived. I thought that maybe there was something going on with the APs so I turned off POE for 5 minutes and turned them back on. All 5 RPis MACs are seen as registered on the APs and the DHCP server says that they are bound but when trying to ping the RPi from the AP it says that there is no IP associated with the MAC and so it cannot ping. I am also unable to SSH into the ones I had revived.

I am unsure of what the next steps I should be taking here to try and elicit the exact problem and determine a solution. Any insights?

Thanks!
optomus
 
Posts: 6
Joined: Wed Nov 30, 2016 10:14 pm

Return to ARMv8

Who is online

Users browsing this forum: No registered users and 1 guest