[FIXED][alarm/kodi-rbp-git][armv7h] libcec doesn't load

Problems with packages? Post here, using [tags] of the package name.

[FIXED][alarm/kodi-rbp-git][armv7h] libcec doesn't load

Postby Iszzy » Fri Jul 13, 2018 8:50 pm

Hi guys,

I'm currently testing Kodi 18 (Leia) and am pretty happy with it (first time able to watch Netflix :D).

The only thing that doesn't work anymore compared to Kodi 17 is CEC via HDMI.

I already created a thread on the Kodi forums: https://forum.kodi.tv/showthread.php?tid=333576

However, this looks like it might be an Archlinux-specific problem.

When looking at kodi.log from Kodi 18, I can see that the messages about libcec being loaded are missing compared to Kodi 17. I have the package libcec-rpi installed on both systems.

Any idea what might be the problem here?

Thanks in advance and best regards,

Timo
Last edited by Iszzy on Sat Jul 14, 2018 8:27 pm, edited 1 time in total.
Iszzy
 
Posts: 5
Joined: Fri Jul 13, 2018 8:42 pm

Re: [alarm/kodi-rbp-git] libcec doesn't get loaded on armv7h

Postby graysky » Fri Jul 13, 2018 10:10 pm

Please post the output of:
Code: Select all
pacman -Qi kodi-rbp-git
graysky
 
Posts: 407
Joined: Sun Jun 26, 2011 6:56 am
Location: /run/user/1000

Re: [alarm/kodi-rbp-git] libcec doesn't get loaded on armv7h

Postby Iszzy » Sat Jul 14, 2018 7:34 am

Hi graysky,

thanks for your answer (on both forums)!

Here's the requested output. I also added the info for the libcec-rpi package in case it's also of interest:

Code: Select all
$ pacman -Qi kodi-rbp-git
Name            : kodi-rbp-git
Version         : 18.0a2.20180621-2
Description     : A software media player and entertainment hub for digital media (Raspberry Pi)
Architecture    : armv7h
URL             : http://kodi.tv
Licenses        : GPL2
Groups          : None
Provides        : xbmc  kodi
Depends On      : bluez-libs  desktop-file-utils  freetype2  fribidi  hicolor-icon-theme  libass  libcdio  libjpeg-turbo  libmariadbclient  libmicrohttpd  libpulse  libssh  libxrandr  lirc  raspberrypi-firmware  libxslt  lzo  python2-pillow  python2-simplejson  smbclient  speex
                  taglib  tinyxml  xorg-xdpyinfo  yajl  libinput  libxkbcommon
Optional Deps   : afpfs-ng: Apple shares support [installed]
                  bluez: Blutooth support
                  python2-pybluez: Bluetooth support [installed]
                  libnfs: NFS shares support [installed]
                  libplist: Limited AirPlay support [installed]
                  libcec-rpi: Pulse-Eight USB-CEC adapter support [installed]
                  lsb-release: log distro information in crashlog [installed]
                  shairplay: Limited AirPlay support [installed]
                  unrar: Archives support
                  unzip: Archives support [installed]
                  upower: Display battery level
Required By     : kodi-dev-rbp-git
Optional For    : None
Conflicts With  : xbmc  kodi  arm-mem-git  shairplay-git
Replaces        : xbmc-rbp-git
Installed Size  : 73.78 MiB
Packager        : Arch Linux ARM Build System <builder+xu4@archlinuxarm.org>
Build Date      : Sun 01 Jul 2018 01:32:59 PM CEST
Install Date    : Fri 06 Jul 2018 08:18:24 PM CEST
Install Reason  : Installed as a dependency for another package    
Install Script  : Yes
Validated By    : Signature


Code: Select all
$ pacman -Qi libcec-rpi
Name            : libcec-rpi
Version         : 4.0.2-1
Description     : Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter (Raspberry Pi)
Architecture    : armv7h
URL             : http://libcec.pulse-eight.com/
Licenses        : GPL
Groups          : None
Provides        : libcec
Depends On      : udev  lockdev  p8-platform  libxrandr  raspberrypi-firmware
Optional Deps   : None
Required By     : None
Optional For    : kodi-rbp-git
Conflicts With  : libcec
Replaces        : None
Installed Size  : 757.00 KiB
Packager        : Arch Linux ARM Build System <builder+xu5@archlinuxarm.org>
Build Date      : Wed 01 Feb 2017 02:42:08 AM CET
Install Date    : Tue 07 Feb 2017 09:39:38 PM CET
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : SHA-256 Sum


Best regards,

Timo
Iszzy
 
Posts: 5
Joined: Fri Jul 13, 2018 8:42 pm


Re: [alarm/kodi-rbp-git] libcec doesn't get loaded on armv7h

Postby Iszzy » Sat Jul 14, 2018 8:25 pm

Hi graysky,

that commit fixed my issue. Many thanks for the great and quick help!

Best regards,

Timo
Iszzy
 
Posts: 5
Joined: Fri Jul 13, 2018 8:42 pm


Return to Packages

Who is online

Users browsing this forum: No registered users and 2 guests