Openbox won't run the autostart script

This forum is for discussion about general software issues.

Openbox won't run the autostart script

Postby andoru » Fri Aug 10, 2018 10:27 pm

I've looked everywhere for a solution for this... but I haven't gotten in the usual pitfalls as many others who had this problem...
I can't get Openbox (and more specifically openbox-session) to run the autostart script in ~/.config/openbox/autostart.

Here's what it contains:

Code: Select all
## Openbox autostart.sh
## ====================
## Note*: some programs, such as 'nm-applet' are run via XDG
autostart.
## Run '/usr/lib/openbox/openbox-xdg-autostart --list' to list any
## XDG autostarted programs.
##
## More information about this can be found at:
## http://openbox.org/wiki/Help:Autostart
##


nitrogen --restore &
conky -qd &
qbittorrent &



I launch Openbox through systemd, here's what /etc/systemd/system/openbox.service contains:

Code: Select all
[Unit]
Description=OpenBox WM Service
After=network.target Xvfb.service

[Service]
User=andoru
ExecStart=/bin/sh -c "DISPLAY=:0 openbox-session"

[Install]
WantedBy=multi-user.target


I have to set it execute a command through sh like that, as openbox needs to have a display specified, since I run it through Xvfb.
Openbox itself runs fine at startup, but it just won't run the commands in the autostart file.
Anyone know what I'm doing wrong...?
andoru
 
Posts: 18
Joined: Fri Jul 20, 2018 5:18 pm

Re: Openbox won't run the autostart script

Postby TheSaint » Sat Aug 11, 2018 12:51 pm

Have you tried to put your scripts in ~/.config/autostart ?
Or perhaps to write a systemd service to start your own script ?
TheSaint
 
Posts: 243
Joined: Mon Jul 23, 2018 7:57 am

Re: Openbox won't run the autostart script

Postby andoru » Sat Aug 11, 2018 10:34 pm

No, but Openbox was supposed to read the script from that path, as it is configured to do so. But I'll see if your solutions help in any way, thanks.
andoru
 
Posts: 18
Joined: Fri Jul 20, 2018 5:18 pm

Re: Openbox won't run the autostart script

Postby TheSaint » Sun Aug 12, 2018 3:18 pm

Did you find error in the journal ?
TheSaint
 
Posts: 243
Joined: Mon Jul 23, 2018 7:57 am

Re: Openbox won't run the autostart script

Postby andoru » Mon Aug 13, 2018 1:26 am

No, there are no errors related to Openbox in the journal unfortunately...
andoru
 
Posts: 18
Joined: Fri Jul 20, 2018 5:18 pm


Return to General

Who is online

Users browsing this forum: No registered users and 1 guest