omxplayer keyboard input no longer working

This forum is for discussion about general software issues.

omxplayer keyboard input no longer working

Postby jazztickets » Tue Aug 21, 2018 3:03 pm

Anyone else's omxplayer keyboard input stop working? I have both rpi2 and 3. The dbuscontrol.sh script works, so i don't think it's dbus.

Code: Select all
[2018-08-14 08:10] [PACMAN] starting full system upgrade
[2018-08-14 08:11] [ALPM] transaction started
[2018-08-14 08:11] [ALPM] upgraded linux-api-headers (4.16.1-1 -> 4.17.11-1)
[2018-08-14 08:11] [ALPM] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
[2018-08-14 08:11] [ALPM] upgraded glibc (2.27-3 -> 2.28-1)
[2018-08-14 08:11] [ALPM-SCRIPTLET] Generating locales...
[2018-08-14 08:11] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2018-08-14 08:11] [ALPM-SCRIPTLET] Generation complete.
[2018-08-14 08:11] [ALPM] upgraded gcc-libs (8.1.1+20180531-1 -> 8.2.0-2)
[2018-08-14 08:11] [ALPM] upgraded gdbm (1.16-1 -> 1.17-1)
[2018-08-14 08:11] [ALPM] upgraded dbus (1.12.8-1 -> 1.12.10-1)
[2018-08-14 08:11] [ALPM] upgraded libutil-linux (2.32.1-1 -> 2.32.1-2)
[2018-08-14 08:11] [ALPM] upgraded avahi (0.7+16+g1cc2b8e-1 -> 0.7+16+g1cc2b8e-2)
[2018-08-14 08:11] [ALPM] upgraded binutils (2.30-5 -> 2.31.1-1)
[2018-08-14 08:11] [ALPM] upgraded icu (61.1-1 -> 62.1-1)
[2018-08-14 08:11] [ALPM] upgraded boost-libs (1.67.0-5 -> 1.67.0-7)
[2018-08-14 08:12] [ALPM] upgraded boost (1.67.0-5 -> 1.67.0-7)
[2018-08-14 08:12] [ALPM] upgraded device-mapper (2.02.180-1 -> 2.02.181-1)
[2018-08-14 08:12] [ALPM] upgraded cryptsetup (2.0.3-2 -> 2.0.4-1)
[2018-08-14 08:12] [ALPM] upgraded perl (5.26.2-2 -> 5.28.0-1)
[2018-08-14 08:12] [ALPM] upgraded libldap (2.4.46-1 -> 2.4.46-2)
[2018-08-14 08:12] [ALPM] upgraded util-linux (2.32.1-1 -> 2.32.1-2)
[2018-08-14 08:12] [ALPM] upgraded libpcap (1.8.1-2 -> 1.9.0-1)
[2018-08-14 08:12] [ALPM] upgraded dhcpcd (7.0.5b-1 -> 7.0.7-1)
[2018-08-14 08:12] [ALPM] upgraded gcc (8.1.1+20180531-1 -> 8.2.0-2)
[2018-08-14 08:13] [ALPM] upgraded python (3.6.6-1 -> 3.7.0-3)
[2018-08-14 08:13] [ALPM] upgraded libtool (2.4.6+40+g6ca5e224-6 -> 2.4.6+42+gb88cebd5-1)
[2018-08-14 08:13] [ALPM] upgraded libatomic_ops (7.6.4-1 -> 7.6.6-1)
[2018-08-14 08:13] [ALPM] upgraded gdb-common (8.1-1 -> 8.1.1-1)
[2018-08-14 08:13] [ALPM] upgraded gdb (8.1-1 -> 8.1.1-1)
[2018-08-14 08:13] [ALPM] upgraded gpgme (1.11.1-1 -> 1.11.1-2)
[2018-08-14 08:13] [ALPM] upgraded harfbuzz (1.8.5-1 -> 1.8.7-1)
[2018-08-14 08:13] [ALPM] upgraded libdrm (2.4.92-1 -> 2.4.93-1)
[2018-08-14 08:13] [ALPM] upgraded libibus (1.5.18-1 -> 1.5.18-2)
[2018-08-14 08:13] [ALPM] upgraded libinput (1.11.2-1 -> 1.11.3-1)
[2018-08-14 08:13] [ALPM] upgraded libmariadbclient (10.1.34-1 -> 10.1.35-1)
[2018-08-14 08:13] [ALPM] upgraded libplist (2.0.0+11+gec9ba8b-1 -> 2.0.0+11+gec9ba8b-2)
[2018-08-14 08:13] [ALPM] upgraded libproxy (0.4.15-6 -> 0.4.15-8)
[2018-08-14 08:13] [ALPM] upgraded libxml2 (2.9.8-2 -> 2.9.8-4)
[2018-08-14 08:13] [ALPM] upgraded mkinitcpio-busybox (1.28.4-1 -> 1.29.2-1)
[2018-08-14 08:13] [ALPM] upgraded linux-raspberrypi (4.14.59-1 -> 4.14.61-1)
[2018-08-14 08:13] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2018-08-14 08:13] [ALPM] upgraded llvm-libs (6.0.1-1 -> 6.0.1-3)
[2018-08-14 08:13] [ALPM] upgraded lvm2 (2.02.180-1 -> 2.02.181-1)
[2018-08-14 08:13] [ALPM] upgraded man-db (2.8.3-2 -> 2.8.4-1)
[2018-08-14 08:13] [ALPM] upgraded openjpeg2 (2.3.0-2 -> 2.3.0-3)
[2018-08-14 08:13] [ALPM] upgraded xcb-proto (1.13-1 -> 1.13-2)
[2018-08-14 08:13] [ALPM] upgraded mpd (0.20.20-2 -> 0.20.20-3)
[2018-08-14 08:13] [ALPM] upgraded ncmpcpp (0.8.2-2 -> 0.8.2-3)
[2018-08-14 08:13] [ALPM] upgraded netctl (1.17-1 -> 1.18-1)
[2018-08-14 08:13] [ALPM] upgraded perl-data-dump (1.23-3 -> 1.23-4)
[2018-08-14 08:13] [ALPM] upgraded perl-encode-locale (1.05-3 -> 1.05-4)
[2018-08-14 08:13] [ALPM] upgraded perl-error (0.17026-1 -> 0.17026-2)
[2018-08-14 08:13] [ALPM] upgraded perl-http-date (6.02-4 -> 6.02-5)
[2018-08-14 08:13] [ALPM] upgraded perl-file-listing (6.04-4 -> 6.04-5)
[2018-08-14 08:13] [ALPM] upgraded perl-html-tagset (3.20-6 -> 3.20-7)
[2018-08-14 08:13] [ALPM] upgraded perl-html-parser (3.72-5 -> 3.72-6)
[2018-08-14 08:13] [ALPM] upgraded perl-lwp-mediatypes (6.02-4 -> 6.02-5)
[2018-08-14 08:13] [ALPM] upgraded perl-uri (1.74-1 -> 1.74-2)
[2018-08-14 08:13] [ALPM] upgraded perl-io-html (1.001-3 -> 1.001-4)
[2018-08-14 08:13] [ALPM] upgraded perl-http-message (6.18-1 -> 6.18-2)
[2018-08-14 08:13] [ALPM] upgraded perl-http-cookies (6.04-2 -> 6.04-3)
[2018-08-14 08:13] [ALPM] upgraded perl-http-daemon (6.01-5 -> 6.01-6)
[2018-08-14 08:13] [ALPM] upgraded perl-http-negotiate (6.01-4 -> 6.01-5)
[2018-08-14 08:13] [ALPM] upgraded perl-net-ssleay (1.85-1 -> 1.85-2)
[2018-08-14 08:14] [ALPM] upgraded perl-io-socket-ssl (2.056-1 -> 2.056-2)
[2018-08-14 08:14] [ALPM] upgraded perl-net-http (6.18-1 -> 6.18-2)
[2018-08-14 08:14] [ALPM] upgraded perl-www-robotrules (6.02-4 -> 6.02-5)
[2018-08-14 08:14] [ALPM] upgraded perl-try-tiny (0.30-1 -> 0.30-2)
[2018-08-14 08:14] [ALPM] upgraded perl-libwww (6.33-1 -> 6.33-2)
[2018-08-14 08:14] [ALPM] upgraded perl-log-message (0.08-3 -> 0.08-4)
[2018-08-14 08:14] [ALPM] upgraded perl-log-message-simple (0.10-3 -> 0.10-4)
[2018-08-14 08:14] [ALPM] upgraded perl-lwp-protocol-https (6.07-1 -> 6.07-2)
[2018-08-14 08:14] [ALPM] upgraded perl-timedate (2.30-4 -> 2.30-5)
[2018-08-14 08:14] [ALPM] upgraded perl-mailtools (2.20-1 -> 2.20-2)
[2018-08-14 08:14] [ALPM] upgraded perl-term-readline-gnu (1.35-4 -> 1.35-5)
[2018-08-14 08:14] [ALPM] upgraded perl-term-ui (0.46-3 -> 0.46-4)
[2018-08-14 08:14] [ALPM] upgraded poppler (0.64.0-1 -> 0.67.0-1)
[2018-08-14 08:14] [ALPM] upgraded poppler-glib (0.64.0-1 -> 0.67.0-1)
[2018-08-14 08:14] [ALPM] upgraded python-appdirs (1.4.3-1 -> 1.4.3-2)
[2018-08-14 08:14] [ALPM] upgraded python-pyparsing (2.2.0-1 -> 2.2.0-2)
[2018-08-14 08:14] [ALPM] upgraded python-six (1.11.0-1 -> 1.11.0-3)
[2018-08-14 08:14] [ALPM] upgraded python-packaging (17.1-1 -> 17.1-2)
[2018-08-14 08:14] [ALPM] upgraded python-setuptools (1:39.2.0-2 -> 1:39.2.0-3)
[2018-08-14 08:14] [ALPM] upgraded python2-olefile (0.45.1-1 -> 0.45.1-2)
[2018-08-14 08:14] [ALPM] upgraded python2-pillow (5.2.0-1 -> 5.2.0-2)
[2018-08-14 08:14] [ALPM] upgraded python2-pybluez (0.22-2 -> 0.22-3)
[2018-08-14 08:14] [ALPM] upgraded python2-simplejson (3.16.0-1 -> 3.16.0-2)
[2018-08-14 08:14] [ALPM] upgraded shared-mime-info (1.9-1 -> 1.10-1)
[2018-08-14 08:14] [ALPM] upgraded qt5-base (5.11.1-1 -> 5.11.1-2)
[2018-08-14 08:14] [ALPM] upgraded raspberrypi-bootloader (20180730-1 -> 20180810-1)
[2018-08-14 08:14] [ALPM] upgraded raspberrypi-bootloader-x (20180730-1 -> 20180810-1)
[2018-08-14 08:14] [ALPM] upgraded rxvt-unicode-terminfo (9.22-6 -> 9.22-7)
[2018-08-14 08:14] [ALPM] upgraded vim-runtime (8.1.0022-1 -> 8.1.0279-1)
[2018-08-14 08:14] [ALPM] upgraded vim (8.1.0022-1 -> 8.1.0279-1)
[2018-08-14 08:14] [ALPM] upgraded youtube-dl (2018.08.04-1 -> 2018.08.04-2)
[2018-08-14 08:14] [ALPM] transaction completed
[2018-08-14 08:14] [ALPM] running '99-linux-raspberrypi.hook'...
[2018-08-14 08:14] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-raspberrypi.preset: 'default'
[2018-08-14 08:14] [ALPM-SCRIPTLET]   -> -k 4.14.61-1-ARCH -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2018-08-14 08:14] [ALPM-SCRIPTLET] ==> Starting build: 4.14.61-1-ARCH
[2018-08-14 08:14] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-08-14 08:14] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-08-14 08:14] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-08-14 08:14] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-08-14 08:14] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-08-14 08:14] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-08-14 08:14] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-08-14 08:14] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-08-14 08:14] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-08-14 08:14] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2018-08-14 08:14] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-08-14 08:14] [ALPM] running 'detect-old-perl-modules.hook'...
[2018-08-14 08:14] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-08-14 08:14] [ALPM] running 'systemd-hwdb.hook'...
[2018-08-14 08:14] [ALPM] running 'systemd-sysusers.hook'...
[2018-08-14 08:14] [ALPM] running 'systemd-tmpfiles.hook'...
[2018-08-14 08:14] [ALPM] running 'systemd-udev-reload.hook'...
[2018-08-14 08:14] [ALPM] running 'systemd-update.hook'...
[2018-08-14 08:14] [ALPM] running 'texinfo-install.hook'...
[2018-08-14 08:14] [ALPM] running 'update-desktop-database.hook'...
[2018-08-14 08:14] [ALPM] running 'update-mime-database.hook'...
[2018-08-14 08:27] [PACMAN] Running '/usr/bin/pacman -Syu'
[2018-08-14 08:27] [PACMAN] synchronizing package lists
[2018-08-14 08:27] [PACMAN] starting full system upgrade
[2018-08-15 00:14] [PACMAN] Running '/bin/pacman -Syuw --noconfirm --noprogressbar'
[2018-08-15 00:14] [PACMAN] synchronizing package lists
[2018-08-15 00:14] [PACMAN] starting full system upgrade
[2018-08-16 00:00] [PACMAN] Running '/bin/pacman -Syuw --noconfirm --noprogressbar'
[2018-08-16 00:00] [PACMAN] synchronizing package lists
[2018-08-16 00:00] [PACMAN] starting full system upgrade
[2018-08-17 00:06] [PACMAN] Running '/bin/pacman -Syuw --noconfirm --noprogressbar'
[2018-08-17 00:06] [PACMAN] synchronizing package lists
[2018-08-17 00:06] [PACMAN] starting full system upgrade
[2018-08-18 00:09] [PACMAN] Running '/bin/pacman -Syuw --noconfirm --noprogressbar'
[2018-08-18 00:09] [PACMAN] synchronizing package lists
[2018-08-18 00:09] [PACMAN] starting full system upgrade
[2018-08-19 00:13] [PACMAN] Running '/bin/pacman -Syuw --noconfirm --noprogressbar'
[2018-08-19 00:13] [PACMAN] synchronizing package lists
[2018-08-19 00:13] [PACMAN] starting full system upgrade
[2018-08-20 00:00] [PACMAN] Running '/bin/pacman -Syuw --noconfirm --noprogressbar'
[2018-08-20 00:00] [PACMAN] synchronizing package lists
[2018-08-20 00:00] [PACMAN] starting full system upgrade
[2018-08-20 09:55] [PACMAN] Running '/usr/bin/pacman -Syu'
[2018-08-20 09:55] [PACMAN] synchronizing package lists
[2018-08-20 09:55] [PACMAN] starting full system upgrade
[2018-08-20 09:55] [ALPM] transaction started
[2018-08-20 09:55] [ALPM] removed libx264 (2:152.20171224-2)
[2018-08-20 09:55] [ALPM] upgraded tzdata (2018e-1 -> 2018e-2)
[2018-08-20 09:56] [ALPM] upgraded glibc (2.28-1 -> 2.28-4)
[2018-08-20 09:56] [ALPM-SCRIPTLET] Generating locales...
[2018-08-20 09:56] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2018-08-20 09:56] [ALPM-SCRIPTLET] Generation complete.
[2018-08-20 09:56] [ALPM] upgraded binutils (2.31.1-1 -> 2.31.1-3)
[2018-08-20 09:56] [ALPM] installed l-smash (2.14.5-1)
[2018-08-20 09:56] [ALPM] installed x264 (2:155.r0a84d986-2)
[2018-08-20 09:56] [ALPM] upgraded graphite (1:1.3.11-1 -> 1:1.3.12-1)
[2018-08-20 09:56] [ALPM] upgraded harfbuzz (1.8.7-1 -> 1.8.8-1)
[2018-08-20 09:56] [ALPM] upgraded p11-kit (0.23.12-1 -> 0.23.13-2)
[2018-08-20 09:56] [ALPM-SCRIPTLET] Created symlink /etc/systemd/user/sockets.target.wants/p11-kit-server.socket -> /usr/lib/systemd/user/p11-kit-server.socket.
[2018-08-20 09:56] [ALPM] upgraded openssl (1.1.0.h-1 -> 1.1.0.i-1)
[2018-08-20 09:56] [ALPM] upgraded shadow (4.5-4 -> 4.6-1)
[2018-08-20 09:56] [ALPM] upgraded llvm-libs (6.0.1-3 -> 6.0.1-4)
[2018-08-20 09:56] [ALPM] upgraded mesa (18.1.5-1 -> 18.1.6-1)
[2018-08-20 09:56] [ALPM] upgraded libglvnd (1.0.0-1 -> 1.1.0-1)
[2018-08-20 09:56] [ALPM] upgraded ffmpeg (1:4.0.2-1 -> 1:4.0.2-2)
[2018-08-20 09:56] [ALPM] upgraded haveged (1.9.2-1 -> 1.9.4-2)
[2018-08-20 09:56] [ALPM] upgraded iproute2 (4.17.0-1 -> 4.18.0-1)
[2018-08-20 09:56] [ALPM] upgraded tevent (1:0.9.36-1 -> 1:0.9.37-1)
[2018-08-20 09:56] [ALPM] upgraded tdb (1.3.15-1 -> 1.3.16-1)
[2018-08-20 09:56] [ALPM] upgraded ldb (1:1.3.4-2 -> 1:1.3.5-1)
[2018-08-20 09:56] [ALPM] upgraded libwbclient (4.8.3-2 -> 4.8.4-1)
[2018-08-20 09:57] [ALPM] upgraded linux-firmware (20180717.8d69bab-1 -> 20180815.f1b95fe-1)
[2018-08-20 09:57] [ALPM] upgraded linux-raspberrypi (4.14.61-1 -> 4.14.62-1)
[2018-08-20 09:57] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2018-08-20 09:57] [ALPM] upgraded man-pages (4.16-1 -> 4.16-2)
[2018-08-20 09:57] [ALPM] upgraded smbclient (4.8.3-2 -> 4.8.4-1)
[2018-08-20 09:57] [ALPM] upgraded mpd (0.20.20-3 -> 0.20.21-1)
[2018-08-20 09:57] [ALPM] upgraded python-setuptools (1:39.2.0-3 -> 1:40.0.0-1)
[2018-08-20 09:57] [ALPM] upgraded raspberrypi-bootloader (20180810-1 -> 20180816-1)
[2018-08-20 09:57] [ALPM] upgraded raspberrypi-bootloader-x (20180810-1 -> 20180816-1)
[2018-08-20 09:57] [ALPM] upgraded wpa_supplicant (1:2.6-11 -> 1:2.6-12)
[2018-08-20 09:57] [ALPM] upgraded xdg-utils (1.1.3-2 -> 1.1.3-3)
[2018-08-20 09:57] [ALPM] transaction completed
[2018-08-20 09:57] [ALPM] running '99-linux-raspberrypi.hook'...
[2018-08-20 09:57] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-raspberrypi.preset: 'default'
[2018-08-20 09:57] [ALPM-SCRIPTLET]   -> -k 4.14.62-1-ARCH -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2018-08-20 09:57] [ALPM-SCRIPTLET] ==> Starting build: 4.14.62-1-ARCH
[2018-08-20 09:57] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-08-20 09:57] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-08-20 09:57] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-08-20 09:58] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-08-20 09:58] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-08-20 09:58] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-08-20 09:58] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-08-20 09:58] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-08-20 09:58] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-08-20 09:58] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2018-08-20 09:58] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-08-20 09:58] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-08-20 09:58] [ALPM] running 'systemd-sysusers.hook'...
[2018-08-20 09:58] [ALPM] running 'systemd-tmpfiles.hook'...
[2018-08-20 09:58] [ALPM] running 'systemd-update.hook'...
[2018-08-20 09:58] [ALPM] running 'texinfo-install.hook'...
[2018-08-20 10:00] [PACMAN] Running 'pacman -S python-pip'
[2018-08-20 10:00] [ALPM] transaction started
[2018-08-20 10:00] [ALPM] installed python-msgpack (0.5.6-2)
[2018-08-20 10:00] [ALPM] installed python-urllib3 (1.23-2)
[2018-08-20 10:00] [ALPM] installed python-chardet (3.0.4-2)
[2018-08-20 10:00] [ALPM] installed python-idna (2.7-3)
[2018-08-20 10:00] [ALPM] installed python-requests (2.19.1-2)
[2018-08-20 10:00] [ALPM] installed python-cachecontrol (0.12.5-4)
[2018-08-20 10:00] [ALPM] installed python-colorama (0.3.9-2)
[2018-08-20 10:00] [ALPM] installed python-distlib (0.2.7-2)
[2018-08-20 10:00] [ALPM] installed python-distro (1.3.0-2)
[2018-08-20 10:00] [ALPM] installed python-webencodings (0.5.1-2)
[2018-08-20 10:00] [ALPM] installed python-html5lib (1.0.1-3)
[2018-08-20 10:00] [ALPM] installed python-lockfile (0.12.2-3)
[2018-08-20 10:00] [ALPM] installed python-progress (1.4-2)
[2018-08-20 10:00] [ALPM] installed python-pytoml (0.1.16-2)
[2018-08-20 10:00] [ALPM] installed python-retrying (1.3.3-4)
[2018-08-20 10:00] [ALPM] installed python-pip (18.0-1)
[2018-08-20 10:00] [ALPM] transaction completed
Last edited by jazztickets on Fri Aug 24, 2018 5:36 pm, edited 1 time in total.
jazztickets
 
Posts: 6
Joined: Fri May 17, 2013 2:35 am

Re: omxplayer keyboard input no longer working

Postby dt23 » Thu Aug 23, 2018 7:32 pm

I just realized I had the same issue on my raspberry pi 1 (B+/armv6h) with omxplayer-git-513.9680057-1. I dont really know how to debug this. I tried over ssh in a tmux session too, although its nonsense. The only thing I could do was ^C.
dt23
 
Posts: 2
Joined: Sat Mar 16, 2013 9:50 pm

Re: omxplayer keyboard input no longer working

Postby TheSaint » Fri Aug 24, 2018 5:44 am

Looks like that the most guilty is python upgrade.
How do you start the program? You might start it in console and see whether errors are coming up.
TheSaint
 
Posts: 152
Joined: Mon Jul 23, 2018 7:57 am

Re: omxplayer keyboard input no longer working

Postby dt23 » Fri Aug 24, 2018 11:34 am

I have nothing but a console, so the only thing I get is:
Code: Select all
which: no xset in (/usr/bin:/bin:/home/amnesia/bin:)
which: no xrefresh in (/usr/bin:/bin:/home/amnesia/bin:)

and this is completely normal.
dt23
 
Posts: 2
Joined: Sat Mar 16, 2013 9:50 pm

Re: omxplayer keyboard input no longer working

Postby jazztickets » Fri Aug 24, 2018 2:53 pm

https://github.com/popcornmix/omxplayer ... yboard.cpp

Basically what's happening is getchar() is always returning -1 on line 95.

The call to tcsetattr on line 28 of Keyboard.cpp is causing it.

Maybe the upgrade to glibc or some change to how the terminal is setup is breaking it.
jazztickets
 
Posts: 6
Joined: Fri May 17, 2013 2:35 am

Re: omxplayer keyboard input no longer working

Postby jazztickets » Fri Sep 07, 2018 1:33 pm

Here is a patch from jehutting that fixes it:
https://github.com/popcornmix/omxplayer ... -419341666

Anyone know why this update is necessary now?
jazztickets
 
Posts: 6
Joined: Fri May 17, 2013 2:35 am

Re: omxplayer keyboard input no longer working

Postby dimetylete » Sat Sep 15, 2018 2:18 pm

I had the same issue too
    rpi3 mode B
    Linux alarmpi 4.14.69-2-ARCH armv7l
    omxplayer-git 513.9680057-1
dimetylete
 
Posts: 1
Joined: Sat Sep 15, 2018 2:08 pm


Return to General

Who is online

Users browsing this forum: No registered users and 0 guests