[linux-veyron] UPDATED - Null pointer dereference error.

Problems with packages? Post here, using [tags] of the package name.

[linux-veyron] UPDATED - Null pointer dereference error.

Postby reesewang » Sun Jan 20, 2019 2:09 am

Hardware: ASUS Chromebit CS10.

I did the installations steps described in https://archlinuxarm.org/platforms/armv ... mebit-cs10 with the tarball ArchLinuxARM-veyron-latest.tar.gz (3.14 kernel). After systemd reaches the target Local File Systems, an error message appears:

Unable to handle kernel NULL pointer dereference at virtual address 00000008

vlcsnap-2019-01-20-10h00m17s604.jpg
vlcsnap-2019-01-20-10h00m17s604.jpg (176.87 KiB) Viewed 301 times

photo_2019-02-17_14-32-03-comp.jpg
photo_2019-02-17_14-32-03-comp.jpg (199.45 KiB) Viewed 72 times


And stack is dumped. The error prevents starting up from progressing further, leaving no login prompt and render the system unusable.

I tried to install with tarball ArchLinuxARM-armv7-chromebook-latest.tar.gz (4.20 kernel) instead and started up with no problem. When I install linux-veyron which switches the system to 3.14 kernel, the problem above shows again.

Any idea how can I pinpoint where the problem is? Is this caused by a kernel module?
I want to use 3.14 ChromeOS kernel instead of 4.20 for Mali GPU support.

Updated: Added a photo of stack trace. Seems systemd-timesyncd triggered the kernel oops, but if I disable the systemd-timesyncd, another process would trigger the kernel oops.
reesewang
 
Posts: 1
Joined: Fri Jan 18, 2019 2:46 pm

Re: [linux-veyron] UPDATED - Null pointer dereference error.

Postby johnbrox » Sun Mar 17, 2019 12:20 pm

I get the same using an Asus c201.
I had ARCHlinux working for some years then things started breaking since around Nov 2018 when systemd upgraded above version 239.2. Downgrading and holding systemd to that version has worked until now, but there is a growing number of packages dependent on systemd.
Would love to know if someone is making the effort to try and fix this.
johnbrox
 
Posts: 1
Joined: Sat Mar 16, 2019 9:38 pm


Return to Packages

Who is online

Users browsing this forum: No registered users and 0 guests