Asus Chromebook Flip C100 Won't Boot

Ask questions about Arch Linux ARM. Please search before making a new topic.

Asus Chromebook Flip C100 Won't Boot

Postby LukeWarmpocket » Thu Mar 19, 2020 7:22 pm

I followed the install instructions on here to the letter, but when I reboot and press Ctrl + U to boot the Arch USB the boot hangs on 2 processes: Network Service and Create Volatile Files and Directories. I've tried hunting for an answer to this problem and while I found another post on here with a user that said they had the same problem and resolved it by downgrading systemd, I'm still lost as to how to accomplish that.

I'm just getting into Arch and have a great deal to learn, so I apologize if this is a stupid question, but any and all help provided will be greatly appreciated.

Thanks
LukeWarmpocket
 
Posts: 1
Joined: Thu Mar 19, 2020 6:13 pm

Re: Asus Chromebook Flip C100 Won't Boot

Postby manamoo » Sat May 02, 2020 11:13 am

Did you ever resolve this? I have the same problem. Thanks.
manamoo
 
Posts: 1
Joined: Sat May 02, 2020 11:02 am

Re: Asus Chromebook Flip C100 Won't Boot

Postby nzchrisw » Thu May 14, 2020 2:58 am

Noobie here... (so treat my input with caution!)

Try following the instructions on this page:
https://github.com/nikolas-n/GNU-Linux- ... Chromebook
relating to archlinuxarm - these are designed to address exactly this problem. Might be easiest to edit it from the terminal shell sudo su from Chrome OS, or from Crouton or a separate (working) arch instance if you have an older one already.

It worked for me from a December 2019 image, but I don't profess to understand systemd or the resolver service enough to know why (but really really wish I did).
I did find it pretty touch-and-go running pacman -Syu though. It messes with the changes and re applying them doesn't seem to always work 100%... The author of the page I cited suggested not updating.. :o(
So I've only been running pacman -Syu to update the package list, and then manually updating what I need to.
This has now caught up with me, so depending on my last backup's state I may try reinstalling from the March 2020 (current) image.
Input from someone with a better understanding of systemd & the name resolver service would definitely help improve all this...

There are a few other helpful resources out there for the C100 and C201, incl. these:
http://kmkeen.com/c100p-tweaks/2015-11- ... 6-680.html (old, but very useful)
and this one which tweaks the mainline kernel for the C201 (so no touchscreen)
https://github.com/urjaman/arch-c201 (if you goto his linux-c201 folder, he links to a page where he sometimes keeps a copy of his bootable binary package)
nzchrisw
 
Posts: 2
Joined: Thu May 14, 2020 2:30 am

Re: Asus Chromebook Flip C100 Won't Boot

Postby kapil » Wed Jul 01, 2020 6:48 am

The problem appears to be with two services systemd-timesyncd and systemd-resolved.

So, after
Code: Select all
mount /dev/sda2 /mnt
you can enter this with
Code: Select all
chroot /mnt
and then within the ArchLinux chroot:
Code: Select all
 systemctl disable systemd-timesyncd
 systemctl disable systemd-resolved


You may also want to do:
Code: Select all
 systemctl enable debug-shell

This will allow you to get a root shell with Alt+VolDn after boot if further debugging is required. Note that this should be disabled once you start using the system on a regular basis. (You don't want anyone using your device to get a root shell for free!)

After this you should be able to boot. However, you may need to create /etc/resolv.conf "by hand" after running wifi-menu.
kapil
 
Posts: 2
Joined: Wed Jul 01, 2020 5:01 am


Return to User Questions

Who is online

Users browsing this forum: No registered users and 1 guest