haveged 1.9.11-1 (armv5tel) code=dumped, signal=SYS

Problems with packages? Post here, using [tags] of the package name.

Re: haveged 1.9.11-1 (armv5tel) code=dumped, signal=SYS

Postby haraldwithtwoehs » Mon Jun 22, 2020 3:07 pm

I tried the SystemCallFilter=uname change and while the daemon started, there is startup logging missing, so there are still other restrictions in there that need to be removed.

The developer is working on a fix that relaxes the sandboxing filters here: https://github.com/jirka-h/haveged/issues/41
Posts: 8
Joined: Sat Oct 21, 2017 2:49 pm

Re: haveged 1.9.11-1 (armv5tel) code=dumped, signal=SYS

Postby tchelovek » Sun Jun 28, 2020 10:06 pm

Hi Folks,

I am experiencing the same issue, on
Code: Select all
Linux alarmpi 5.4.45-1-ARCH #1 SMP PREEMPT Mon Jun 15 03:53:46 UTC 2020 armv7l GNU/Linux

Code: Select all
haveged 1.9.12-1

I only noticed this, while concerning myself with package signing, otherwise I wouldn't have the slightest hint of it.

As I gather from the conversation, the issue is present in every fresh install of Arch Linux Arm and causing degradation by permanently restarting haveged and producing core-dumps in the process.

While I don't have the slightest indication of what is done for remedy, I ask myself if there should be some kind of immediate first aid distributed thru pacman repositories ?

Talking about remedy, the suggestion made a few remarks earlier
Still a problem with haveged 1.9.12-1 on armv7l, but adding `uname` to the syscall filter seems to fix the problem:

Code: Select all
$ cat /run/systemd/system/haveged.service.d/override.conf

works for me too, alas only till the next reboot. Everything I added to /run... is gone after rebooting. Putting the override.conf to either
Code: Select all
Code: Select all
survives booting, but produces a warning
Code: Select all
Warning: The unit file, source configuration file or drop-ins of haveged.service changed on disk. Run 'systemctl daemon-reload' to reload units.
, so I guess I didn't pick the right place for the override to make the system happy.

Addendum: If the
Code: Select all
directive is placed directly in the
Code: Select all
after the [Service] tag, the warning stays away and everything looks fine. Probably the extra .conf file gets acted on, when the writing to disk has been done with.

Also, I guess, there should be a note with respect to haveged at the download page, since haveged is essential to pacman key handling, if I understand correctly.
ODROID C1 ( armv7h ), Raspberry Pi 2B+ ( armv7h ), 2 x Raspberry Pi B+ ( armv6h ), Raspberry Pi4 (armv7l)
Posts: 11
Joined: Sat Mar 07, 2015 1:33 pm
Location: Yes

Re: haveged 1.9.11-1 (armv5tel) code=dumped, signal=SYS

Postby bulletmark » Mon Jun 29, 2020 1:12 am

Some of you guys here are fixing haveged but note the wiki at https://archlinuxarm.org/platforms/armv ... berry-pi-3 (and https://archlinuxarm.org/platforms/armv6/raspberry-pi) implies that the recommended approach nowadays is to replace haveged with rngd. That's what I did to address this issue.
Posts: 54
Joined: Tue Oct 13, 2015 10:17 pm

Re: haveged 1.9.11-1 (armv5tel) code=dumped, signal=SYS

Postby kriztioan » Mon Jun 29, 2020 1:52 am

@xiretza Very interesting deep dive into the inner workings causing the issue!

@tchelovek The override can be added using the following command, which also takes care off putting the file in the correct place, etc.:

Code: Select all
sudo systemctl edit haveged

@bulletmark The issue is not only impacting the Raspberry-Pi, but also other systems for which rngd is not an option, so for one I'm glad there is the override-workaround.
Posts: 33
Joined: Sat Apr 29, 2017 1:32 am

Re: haveged 1.9.11-1 (armv5tel) code=dumped, signal=SYS (SOL

Postby kriztioan » Thu Jul 02, 2020 10:03 pm

haveged-1.9.13-1 solves the issue.

FYI The override is removed with
Code: Select all
sudo systemctl revert haveged
Posts: 33
Joined: Sat Apr 29, 2017 1:32 am


Return to Packages

Who is online

Users browsing this forum: No registered users and 1 guest