Raspberry pi 4b: No audio device

This forum is for topics dealing with problems with software specifically in the ARMv7h repo.

Raspberry pi 4b: No audio device

Postby magpi » Fri Jul 31, 2020 5:21 pm

Hi,
(I am no native speaker...)

My SOC is a Raspberry Pi 4B. I run it with a vnc connection and a openbox setup.

At first I installed Raspberry OS on a SDcard and audio via 3.5mm jack works fine.

Then I switched to ArchARM. I am very happy with it ... beside one thing: I have no sound.

aplay -l
aplay: device_list:274: no soundcards found...

/boot/config.txt contains

framebuffer_width=1910
framebuffer_height=1130
hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=82
dtparam=audio=on

[pi4]
max_framebuffers=2

[all]
gpu_mem=76

dtoverlay=disable-bt

which had worked on the Raspberry OS. But I want ArchARM ! ;)

I searched the forum and found -- beside the dtparam=audio=on nothing relevant.

lsmod shows:
Module Size Used by
8021q 32768 0
garp 16384 1 8021q
stp 16384 1 garp
mrp 20480 1 8021q
llc 16384 2 garp,stp
btsdio 16384 0
bluetooth 364544 1 btsdio
ecdh_generic 16384 1 bluetooth
ecc 36864 1 ecdh_generic
brcmfmac 241664 0
brcmutil 16384 1 brcmfmac
bcm2835_v4l2 49152 0
bcm2835_codec 36864 0
bcm2835_isp 32768 0
cfg80211 704512 1 brcmfmac
bcm2835_mmal_vchiq 28672 3 bcm2835_isp,bcm2835_codec,bcm2835_v4l2
v4l2_mem2mem 28672 1 bcm2835_codec
videobuf2_vmalloc 16384 1 bcm2835_v4l2
videobuf2_dma_contig 20480 2 bcm2835_isp,bcm2835_codec
videobuf2_memops 16384 2 videobuf2_dma_contig,videobuf2_vmalloc
videobuf2_v4l2 24576 4 bcm2835_isp,bcm2835_codec,bcm2835_v4l2,v4l2_mem2mem
videobuf2_common 53248 5 bcm2835_isp,bcm2835_codec,bcm2835_v4l2,v4l2_mem2mem,videobuf2_v4l2
videodev 225280 6 bcm2835_isp,bcm2835_codec,videobuf2_common,bcm2835_v4l2,v4l2_mem2mem,videobuf2_v4l2
raspberrypi_hwmon 16384 0
iproc_rng200 16384 0
rng_core 16384 1 iproc_rng200
mc 36864 6 bcm2835_isp,bcm2835_codec,videobuf2_common,videodev,v4l2_mem2mem,videobuf2_v4l2
rpivid_mem 16384 0
uio_pdrv_genirq 16384 0
uio 20480 1 uio_pdrv_genirq
sch_fq_codel 20480 7
snd_bcm2835 24576 0
snd_pcm 94208 1 snd_bcm2835
snd_timer 32768 1 snd_pcm
snd 69632 3 snd_timer,snd_bcm2835,snd_pcm
drm 434176 0
drm_panel_orientation_quirks 16384 1 drm
ip_tables 28672 0
x_tables 32768 1 ip_tables
ipv6 475136 46
nf_defrag_ipv6 16384 1 ipv6


How can I activate audio on the 3.5mm jack?

Cheers!
magpi
magpi
 
Posts: 3
Joined: Fri Jul 31, 2020 5:02 pm

Re: Raspberry pi 4b: No audio device

Postby magpi » Sat Aug 01, 2020 9:29 am

Hi,

has been fixed. It has been a permission problem.

Cheers!
magpi
magpi
 
Posts: 3
Joined: Fri Jul 31, 2020 5:02 pm


Return to ARMv7h

Who is online

Users browsing this forum: No registered users and 0 guests

cron