Installation Help

This forum is for Marvell Kirkwood devices such as the GoFlex Home/Net, PogoPlug v1/v2, SheevaPlug, and ZyXEL devices.

Installation Help

Postby mlong » Fri Nov 12, 2010 4:47 pm

I'm alittle confused working through the Installation instructions. It might be that I'm not that familar with linux/unix.

Under the installation #4 & #5 seem to be the same instructions; copy the installer folder to the usb. Is this because one is for Win and the other for Linux?
Then #6 wants uboot.bin copied to the uboot directory, but thats where it already resides. Should the uboot.bin be copied to the usb root?

If #4 & #5 are the same and #6 should be to copied to the usb then rootfs.tar.gz, uImage, modules.tar.gz, initrd and uboot.bin should be the only items on the usb?

Be kind to the n00b.

Posts: 2
Joined: Fri Nov 12, 2010 4:08 pm

Re: Installation Help

Postby crimsonredmk » Fri Nov 12, 2010 5:36 pm

Copy the contents of the install folder to the USB drive, not the install folder itself.
Remember, Arch Linux ARM is completely donation-supported, and is totally awesome.
Site Admin
Posts: 433
Joined: Wed Dec 30, 2009 5:17 pm
Location: #archlinux-arm on

Re: Installation Help

Postby mlong » Sat Nov 13, 2010 5:13 am

I'm receiving this message when trying to run the runme.php

PHP Notice: Undefined index: OS in ~work/sheevaplug-installer/runme.php on line 7
Posts: 2
Joined: Fri Nov 12, 2010 4:08 pm

Re: Installation Help

Postby ravikiran7785 » Wed Nov 24, 2010 8:27 pm

which OS are you using?
Posts: 1
Joined: Wed Nov 24, 2010 8:26 pm

Re: Installation Help

Postby eblack » Sun Nov 28, 2010 10:21 am

As a fellow Arch Linux ARM install and SheevaPlug "n00b", I will share how I got past step 12 of the installer, after I invested an estimated 12-15 hours of research and trial-and-error. :mrgreen:

If you are running a 64-bit Linux distro, make sure that you have a 64-bit OpenOCD installed -

I modified the runme.php file in the root of the SheevaPlug Installer directory. -

This file includes these modifications:
[*] Added "php" after "<?" on line 1; otherwise running the installer simply prints the file contents to the console without executing on my Arch Linux 64-bit install
[*] Commented out lines 7-8 to get rid of the "Undefined index: OS" error. If you are using Windows, then modify line 3 like this:
Code: Select all

[*] Commented out lines 43-44 to get rid of an error message that results regardless of whether I run the installer as root

To get OpenOCD working, I copied the sheevaplug.cfg from my host's OpenOCD (/usr/share/openocd/scripts/board/sheevaplug.cfg) to overwrite the corresponding file in the SheevaPlug Installer (*installer_root_directory*/uboot/openocd/config/board/sheevaplug.cfg). If this file does not exist on your system, you can get it here -

The script still says "openocd FAILED" when I execute the installer, due to one of these messages:
Code: Select all
Warn : use 'feroceon.cpu' as target identifier, not '0'
Error: JTAG scan chain interrogation failed: all zeroes
Error: Check JTAG interface, timings, target power, etc.

However, I can see on the serial console the commands executing on the SheevaPlug as expected, and within 6 minutes, Arch Linux ARM install Linux is all booted up, ready for me to log in.

I successfully installed Arch Linux ARM install Linux multiple times on my SheevaPlug to make sure the modified installer script worked without killing any small appliances in my vicinity, but I must admit that this is my first time editing PHP, so use at your own risk!

I hope this helps to save someone a few hours of research. :D


Edited 11/30/2010 - replaced URL for sheevaplug.cfg on (previous URL returned "Unknown Paste ID" error)
Posts: 5
Joined: Sun Nov 28, 2010 8:48 am

Re: Installation Help

Postby begunfx » Wed Dec 08, 2010 6:44 pm

mlong wrote:I'm receiving this message when trying to run the runme.php

PHP Notice: Undefined index: OS in ~work/sheevaplug-installer/runme.php on line 7

I have the same problem. I'm running Ubuntu (Virtual through parallels) 10.04. I think it may be that version of Ubuntu. Cause I had run the sheevaplug installer a while ago and it worked fine, but I was using Ubuntu 9.04 at the time. I read somewhere on the forum that it may be that version of Ubuntu.

Does anyone else agree with that?

When I have some time, I'll install v 9.04 again as a virtual machine and try to run it from there to see if it makes any difference.
Posts: 9
Joined: Sat Dec 04, 2010 1:26 am

Re: Installation Help

Postby begunfx » Sat Dec 11, 2010 12:28 am

Okay, I did confirm that the runme.php file will run on Ubuntu 9.04 but not 10.04. However for some reason, I can't get linux to see the jtag port on the plug. The install fails when it tries to talk to that port. Any ideas or suggestions? I'm a bit stuck.
Posts: 9
Joined: Sat Dec 04, 2010 1:26 am

Re: Installation Help

Postby begunfx » Tue Dec 14, 2010 7:14 pm

Update: Still having trouble accessing my jtag using PUTTY. HOWEVER, I did find a post at that will help with the running Ubuntu 10.04.

Here's the link: ... pic=1623.0

Hope this helps someone.

Posts: 9
Joined: Sat Dec 04, 2010 1:26 am

Re: Installation Help

Postby begunfx » Wed Jan 12, 2011 6:41 am

Hey Guys. So accessing my plug using the serial console is working, however, I'm still having difficulties flashing the plug with the Arch Linux ARM distro. I followed all the directions both here and at, and it fails. I followed the "if it fails do this" instructions, and tweaked the runme.php file, but it still craps out. I tried running the runme.php with and without a console session open. When it was open, when I executed the runme.php the plug rebooted, and then the runme.php would fail. I also tried installing openocd on ubuntu 10.10 and did a symlink to the one in the sheevaplug installer.

Here's the output:

begun@ubuntu:~/sheevaplug-installer-v1.0 -> sudo php ./runme.php mmc

**** exec(modprobe ftdi_sio vendor=0x9e88 product=0x9e8f)
**** Preparing environment variables file ...
reading uboot/uboot-env/uboot-dflt.txt
uboot/uboot-env/fw_setenv baudrate 115200
CRC read error on uboot-env.bin: Success
uboot/uboot-env/fw_setenv loads_echo 0
uboot/uboot-env/fw_setenv ipaddr
uboot/uboot-env/fw_setenv serverip
uboot/uboot-env/fw_setenv rootpath /mnt/ARM_FS/
uboot/uboot-env/fw_setenv netmask
uboot/uboot-env/fw_setenv stdin serial
uboot/uboot-env/fw_setenv stdout serial
uboot/uboot-env/fw_setenv stderr serial
uboot/uboot-env/fw_setenv console console=ttyS0,115200 mtdparts=nand_mtd:0xc0000@0\(uboot\)ro,0x1ff00000@0x100000\(root\)
uboot/uboot-env/fw_setenv mainlineLinux no
uboot/uboot-env/fw_setenv CASset min
uboot/uboot-env/fw_setenv enaMonExt no
uboot/uboot-env/fw_setenv enaCpuStream no
uboot/uboot-env/fw_setenv enaWrAllo no
uboot/uboot-env/fw_setenv pexMode RC
uboot/uboot-env/fw_setenv disL2Cache no
uboot/uboot-env/fw_setenv setL2CacheWT yes
uboot/uboot-env/fw_setenv disL2Prefetch yes
uboot/uboot-env/fw_setenv enaICPref yes
uboot/uboot-env/fw_setenv enaDCPref yes
uboot/uboot-env/fw_setenv sata_dma_mode yes
uboot/uboot-env/fw_setenv MALLOC_len 1
uboot/uboot-env/fw_setenv ethprime egiga0
uboot/uboot-env/fw_setenv netbsd_en no
uboot/uboot-env/fw_setenv vxworks_en no
uboot/uboot-env/fw_setenv bootargs_root root=/dev/nfs rw
uboot/uboot-env/fw_setenv bootargs_end :::DB88FXX81:eth0:none
uboot/uboot-env/fw_setenv image_name uImage
uboot/uboot-env/fw_setenv bootcmd tftpboot 0x2000000 \$\(image_name\)\;setenv bootargs \$\(console\) \$\(bootargs_root\) nfsroot=\$\(serverip\):\$\(rootpath\) ip=\$\(ipaddr\):\$\(serverip\)\$\(bootargs_end\) \$\(mvNetConfig\) \$\(mvPhoneConfig\)\; bootm 0x2000000\;
uboot/uboot-env/fw_setenv standalone fsload 0x2000000 \$\(image_name\)\;setenv bootargs \$\(console\) root=/dev/mtdblock0 rw ip=\$\(ipaddr\):\$\(serverip\)\$\(bootargs_end\) \$\(mvPhoneConfig\)\; bootm 0x2000000\;
uboot/uboot-env/fw_setenv bootdelay 3
uboot/uboot-env/fw_setenv disaMvPnp no
uboot/uboot-env/fw_setenv ethaddr 00:50:43:01:41:6F
uboot/uboot-env/fw_setenv ethmtu 1500
uboot/uboot-env/fw_setenv mvPhoneConfig mv_phone_config=dev0:fxs,dev1:fxs
uboot/uboot-env/fw_setenv mvNetConfig mv_net_config=\(00:11:88:0f:62:81,0:1:2:3\),mtu=1500
uboot/uboot-env/fw_setenv usb0Mode host
uboot/uboot-env/fw_setenv yuk_ethaddr 00:00:00:EE:51:81
uboot/uboot-env/fw_setenv nandEcc 1bit
uboot/uboot-env/fw_setenv netretry no
uboot/uboot-env/fw_setenv rcvrip
uboot/uboot-env/fw_setenv loadaddr 0x02000000
uboot/uboot-env/fw_setenv autoload no
uboot/uboot-env/fw_setenv enaAutoRecovery yes
uboot/uboot-env/fw_setenv ethact egiga0
reading uboot/uboot-env/uboot-mmc-custom.txt
uboot/uboot-env/fw_setenv bootargs_root root=/dev/mmcblk0p2 rootdelay=5
uboot/uboot-env/fw_setenv ethaddr 00:50:43:01:41:6F
uboot/uboot-env/fw_setenv real_bootcmd setenv bootargs \$\(bootargs_console\) \$\(bootargs_root\)\; mmcinit\; ext2load mmc 0:1 0x800000 /uImage\; bootm 0x00800000
uboot/uboot-env/fw_setenv bootargs_console console=ttyS0,115200
uboot/uboot-env/fw_setenv bootcmd run recover1
uboot/uboot-env/fw_setenv recover1 setenv mainlineLinux yes\; setenv arcNumber 2097\; setenv bootcmd run recover2\; saveenv\; reset
uboot/uboot-env/fw_setenv recover2 run recover3\; setenv bootcmd \$\(real_bootcmd\)\; saveenv\; setenv bootargs \$\(bootargs_console\) root=/dev/ram0 rw ramdisk=0x01100000,8M install_type=mmc\; bootm 0x00800000 0x01100000
uboot/uboot-env/fw_setenv recover3 usb start\; fatload usb 0 0x00800000 uImage\; fatload usb 0 0x01100000 initrd

**** Burning uboot and environment variables ... This will take few minutes ...
Open On-Chip Debugger 0.2.0 (2009-07-26-14:56) Release
$URL: ... /openocd.c $
For bug reports, read
2000 kHz
jtag_nsrst_delay: 200
jtag_ntrst_delay: 200
dcc downloads are enabled
Segmentation fault
**** openocd FAILED
**** Is the mini USB cable connected?
**** Try powering down, then replugging the Sheevaplug
Posts: 9
Joined: Sat Dec 04, 2010 1:26 am

Re: Installation Help

Postby eblack » Thu Jan 13, 2011 12:35 am

begunfx wrote:**** Burning uboot and environment variables ... This will take few minutes ...
Open On-Chip Debugger 0.2.0 (2009-07-26-14:56) Release

Are you sure that you are using the Ubuntu 10.10 version of OpenOCD, v. 0.4 (

I would double-check the symlink to make sure it points to the Ubuntu OpenOCD.
Posts: 5
Joined: Sun Nov 28, 2010 8:48 am


Return to Marvell Kirkwood

Who is online

Users browsing this forum: No registered users and 2 guests