Kodi no longer plays videos loaded over the network

Ask questions about Arch Linux ARM. Please search before making a new topic.

Kodi no longer plays videos loaded over the network

Postby jonnybarnes » Fri Sep 29, 2017 10:31 am

I have a computer with my media, I have nginx installed that allows that media directory to be accessible over http.

This works with Kodi, it understands the html nginx serves up and gives me a nice list of folders and files so I can easily watch my media downstairs on my television. I have Kodi running on a raspberry Pi 2.

Though I don’t have all the time in the world to watch stuff. So it had been a while. I SSH’d into my pi-box yesterday, updated my packages with pacman, rebooted and went to try and use kodi.

On selecting a file to play, the system would hang and then kodi would restart. Digging around this is what’s happening:

Code: Select all
sudo coredumpctl info 284
           PID: 284 (kodi.bin)
           UID: 994 (kodi)
           GID: 994 (kodi)
        Signal: 6 (ABRT)
     Timestamp: Fri 2017-09-29 11:17:39 BST (6min ago)
  Command Line: /usr/lib/kodi/kodi.bin --standalone -l /run/lirc/lircd
    Executable: /usr/lib/kodi/kodi.bin
 Control Group: /system.slice/kodi.service
          Unit: kodi.service
         Slice: system.slice
       Boot ID: 990dfebf68424e93b84738a4d42fa718
    Machine ID: a49f512138e247ad9cdc3461c35f2b5c
      Hostname: alarmpi
       Storage: /var/lib/systemd/coredump/core.kodi\x2ebin.994.990dfebf68424e93b84738a4d42fa718.284.1506680259000000.lz4
       Message: Process 284 (kodi.bin) of user 994 dumped core.

                Stack trace of thread 371:
                #0  0x00000000745081d8 raise (libc.so.6)


Does anyone have any idea how I can fix this?

EDIT: found where kodi keeps its crash logs. They all end with this line:
Code: Select all
DEBUG: ffmpeg[590FC350]: Assertion frame->data[i] failed at libavcodec/utils.c:891
jonnybarnes
 
Posts: 4
Joined: Tue Jan 20, 2015 1:28 pm

Re: Kodi no longer plays videos loaded over the network

Postby fooxl » Fri Sep 29, 2017 11:53 am

Is /dev/vcsm missing?

https://github.com/archlinuxarm/PKGBUIL ... 2d63967904

If yes, you can either downgrade the kernel or build your own with CONFIG_BCM_VC_SM=y
fooxl
 
Posts: 1
Joined: Fri Sep 29, 2017 11:51 am

Re: Kodi no longer plays videos loaded over the network

Postby jonnybarnes » Fri Sep 29, 2017 1:44 pm

/dev/vcsm is indeed missing, downgrading the kernel has indeed fixed video playback.

It seems this PR might get things working again on the newer kernels: https://github.com/archlinuxarm/PKGBUILDs/pull/1520
jonnybarnes
 
Posts: 4
Joined: Tue Jan 20, 2015 1:28 pm


Return to User Questions

Who is online

Users browsing this forum: No registered users and 3 guests